Catera Strut replacement & Battery/Alternator problems
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
Cadillac Catera and Cimarron Forum Discussion, Catera Strut replacement & Battery/Alternator problems in Past Cadillac Vehicle Discussion; Hello All. As my name suggests I'm now the owner of my Grandmother's 1997 Catera. The car is 55,000 miles ...
  1. #1
    GransCatera is offline Cadillac Owners Member
    Automobile(s): 1998 Catera
    Join Date
    Nov 2010
    Posts
    9

    Catera Strut replacement & Battery/Alternator problems

    Hello All. As my name suggests I'm now the owner of my Grandmother's 1997 Catera. The car is 55,000 miles and in wonderful shape overall... but now just 2 weeks into my ownership it has decided to start giving me headaches.

    1) The front struts are leaking and will need to be replaced. I'm all set to do this myself but have hit a small snag. Replacement struts I've found online don't seem to have the bracket which holds the hydraulic hose and electrical wires (and presumably keeps them from getting snagged as the wheels turn). I don't have easy access to a welder, so even if I cut off the old bracket I can't attach it to the replacement strut. Do you know of any replacement struts that already have a new bracket welded on?

    2) The battery up and died a couple of days ago. It tested as having a bad cell and was replaced under warranty. So now I have a new battery but the cockpit gauge is telling me that I may have another problem. When the car is running it reads 8V (I imagine it should be 12V) and when the engine is off it reads 3V (right above the red). I suspect the alternator is failing to charge the battery and probably needs a new regulator. However, could it simply be the gauge? I'll probably find out in a couple of days if it fails to start again...

    Thanks for the advice!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    elvin315's Avatar
    elvin315 is offline Cadillac Owners Connoisseur
    Automobile(s): Platinum 2001 Cadillac Catera Sport
    Join Date
    Jan 2007
    Location
    Catskill, NY
    Age
    60
    Posts
    1,608

    Re: Catera Strut replacement & Battery/Alternator problems

    The best I can do for you is point you to my article on Catera Suspension Upgrades. It includes struts & shocks. Maybe it contains other struts you didn't know about. Read the whole thing though. You might want to check and replace the control arm bushings while you're messing under the car.

    http://cateraowners.forumotion.com/s...1-t108.htm#409

  4. #3
    USEDCAT is offline Cadillac Owners Fanatic
    Automobile(s): Catera 2001
    Join Date
    May 2005
    Age
    63
    Posts
    343

    Re: Catera Strut replacement & Battery/Alternator problems

    Quote Originally Posted by GransCatera View Post
    Hello All. As my name suggests I'm now the owner of my Grandmother's 1997 Catera. The car is 55,000 miles and in wonderful shape overall... but now just 2 weeks into my ownership it has decided to start giving me headaches.

    1) The front struts are leaking and will need to be replaced. I'm all set to do this myself but have hit a small snag. Replacement struts I've found online don't seem to have the bracket which holds the hydraulic hose and electrical wires (and presumably keeps them from getting snagged as the wheels turn). I don't have easy access to a welder, so even if I cut off the old bracket I can't attach it to the replacement strut. Do you know of any replacement struts that already have a new bracket welded on?

    2) The battery up and died a couple of days ago. It tested as having a bad cell and was replaced under warranty. So now I have a new battery but the cockpit gauge is telling me that I may have another problem. When the car is running it reads 8V (I imagine it should be 12V) and when the engine is off it reads 3V (right above the red). I suspect the alternator is failing to charge the battery and probably needs a new regulator. However, could it simply be the gauge? I'll probably find out in a couple of days if it fails to start again...

    Thanks for the advice!
    For the voltage problem I suggest you check the Positive Battery cable for cracks and insulation burn-off. These are notoriously common to go after a few years and will give you bad start, charging and other problems till thy break-off. You may also want to check the serpentine belt if it appears too loose. There is an automatic tensioner but when the belts get old/worn out these go out of tensioner range and you may have slipping and charging issues.

    The following is a great site for sourcing and understanding as well as finding part numbers,

    http://www.compnine.com/index.php?s=...585&makecode=K

    Good luck.

  5. #4
    GransCatera is offline Cadillac Owners Member
    Automobile(s): 1998 Catera
    Join Date
    Nov 2010
    Posts
    9

    Re: Catera Strut replacement & Battery/Alternator problems

    Well I've put the strut replacement on back burner for the moment, I will probably see if buying OEM replacements from GM will have the brackets, if not I might pony up and pay someone to replace them.

    As far as the battery discharging goes, it is still a mystery. First off, I assumed the bottom of the car's voltmeter scale was 0V in the previous post which is obviously wrong (but I can't find out if it is 10V, 12V, or something else from posts on this site). When the alternator is running the voltmeter reads just above the middle line. When the engine is off the battery reads lower (as it should) but if I leave the car alone for two or three days it is right down to just above the red zone. I've had the battery tested and also the alternator. Both check out, although the alternator does read a bit low at 13.87V when loaded. I also did a drain test but the car is only drawing 11.1mA when sitting. Maybe this is normal and I'm just being paranoid since this is my first car with a voltmeter! Any of you have the same sort of thing with your voltmeters?

  6. #5
    R-Caddy's Avatar
    R-Caddy is offline Cadillac Owners Enthusiast
    Automobile(s): 2 1997 Cateras: black&ocean green
    Join Date
    Jul 2005
    Location
    Savannah, GA
    Age
    29
    Posts
    698

    Re: Catera Strut replacement & Battery/Alternator problems

    THe KYB struts I bought have brakets for the hoses. The same strut is used for both sides, so they include both brackets

  7. #6
    AHazzardToAll's Avatar
    AHazzardToAll is offline Cadillac Owners Enthusiast
    Automobile(s): 1999 Catera Sport
    Join Date
    Jun 2007
    Location
    Mooresville, IN
    Age
    24
    Posts
    677

    Re: Catera Strut replacement & Battery/Alternator problems

    Quote Originally Posted by GransCatera View Post
    Well I've put the strut replacement on back burner for the moment, I will probably see if buying OEM replacements from GM will have the brackets, if not I might pony up and pay someone to replace them.

    As far as the battery discharging goes, it is still a mystery. First off, I assumed the bottom of the car's voltmeter scale was 0V in the previous post which is obviously wrong (but I can't find out if it is 10V, 12V, or something else from posts on this site). When the alternator is running the voltmeter reads just above the middle line. When the engine is off the battery reads lower (as it should) but if I leave the car alone for two or three days it is right down to just above the red zone. I've had the battery tested and also the alternator. Both check out, although the alternator does read a bit low at 13.87V when loaded. I also did a drain test but the car is only drawing 11.1mA when sitting. Maybe this is normal and I'm just being paranoid since this is my first car with a voltmeter! Any of you have the same sort of thing with your voltmeters?
    This in normal, you are fine.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting