Funky heater problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 2 of 2
Cadillac Catera and Cimarron Forum Discussion, Funky heater problem in Past Cadillac Vehicle Discussion; I just replaced my heater control valve following the excellent advice I found on this forum after my cat started ...
  1. #1
    graphicsman is offline Cadillac Owners Member
    Automobile(s): 1999 Catera
    Join Date
    Jun 2006
    Posts
    57

    Funky heater problem

    I just replaced my heater control valve following the excellent advice I found on this forum after my cat started dumping fluid down the back passenger side of the engine. Thanks!


    However, I know have an odd heater problem. I get no heat, even if I set temp to max. However, if I turn the temp all the way down and then quickly to something like 78F, I get heat just fine. Any thoughts? All the lines look okay and I'm pretty darn sure I put everything on in the right position.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    frank moran is offline Cadillac Owners Fanatic
    Automobile(s): Catera, ..
    Join Date
    Jan 2007
    Location
    canton,ga.
    Age
    70
    Posts
    231

    Re: Funky heater problem

    You may have the hoses on the wrong ports, switch the hoses and you should be OK. I know from experience, I just did this repair and I put them on incorretly.



    Quote Originally Posted by graphicsman View Post
    I just replaced my heater control valve following the excellent advice I found on this forum after my cat started dumping fluid down the back passenger side of the engine. Thanks!


    However, I know have an odd heater problem. I get no heat, even if I set temp to max. However, if I turn the temp all the way down and then quickly to something like 78F, I get heat just fine. Any thoughts? All the lines look okay and I'm pretty darn sure I put everything on in the right position.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting