*MY ISSUES* - Somebody shoot me.
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
Cadillac Catera and Cimarron Forum Discussion, *MY ISSUES* - Somebody shoot me. in Past Cadillac Vehicle Discussion; Hey guys... - First and foremost, my Catera is a 2000. I have NO desire to get rid of my ...
  1. #1
    KnockOut is offline Cadillac Owners Member
    Automobile(s): Catera
    Join Date
    Mar 2007
    Posts
    19

    *MY ISSUES* - Somebody shoot me.

    Hey guys...

    - First and foremost, my Catera is a 2000. I have NO desire to get rid of my car, but I'm so frusterated that the thought of something different sounds better everyday. (Sound familiar?)

    1. An electrical problem. Here's where I need help, because I can't lose my job over the same BS constantly happening. I have the wierdest problem in the WORLD, and I've heard every solution known to man. I came here hoping somebody had the exact same problem, or could help me pin-point what it is. My car will work PERFECTLY fine for weeks on end, sometimes even MONTHS - than I reach a point where it drags to a start - than doesn't start at all!! I can drive my car one night, wake up the next morning to it completely DEAD. Please, I appreciate any advice I can get - but I've already checked the basic components you'd instantly think from a dead vehicle. New battery, checked my alternator - no good. I have to come to a Cadillac forum because anybody else I talk to will give me the most generic answers...

    - Here's the kicker. It dies to a point that it sometimes can't even be JUMPED. My dad recently took some of the fuses out of the box above the battery, cleaned off some corrosion and it started working again... BUT THIS IS WHAT ALWAYS HAPPENS!!! Everytime I think I find the source, it's a temporary fix... because now, eventhough those fuses are clean and it got it started again last time - why would it not be starting again now?? I've heard it could be my OnStar, I've heard it all - and I can only hope somebody here can relate and help me fix this sh*t once and for all. I'm litterally about to sell it, and I'm not too happy about that. It runs smooth when it's started, and I've had no REAL technical problems outside of an electric fritz. I forgot to mention that my radio sometimes SHORTS OUT as well, and that's why I think that all of these problems are linked! HELP! It's saturday, I'm trying to solve this problem before work on Monday, or especially before I garage it and cough up tons of dough -

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    ondale is offline Cadillac Owners Fanatic
    Automobile(s): 2001 Catera Sport
    Join Date
    Mar 2004
    Location
    Chicago
    Posts
    147

    Re: *MY ISSUES* - Somebody shoot me.

    Have you checked the "POSITIVE" power cable that runs from the alternator /starter to the battery. In my 97 Catera, I put in a new battery and alternator and got the random "won't start". When the repair shop removed the main "power cable" they discovered that the wire was exposed on the underside and was touching metal, shorting out starter. Once I had that cable replaced, I never had the problem again. I no longer have the car, now driving a 2001 Catera Sport. Hope this helps

    PS welcome to the forum.

  4. #3
    Army_MP_From_MO's Avatar
    Army_MP_From_MO is offline Cadillac Owners Fanatic
    Automobile(s): 1999 Cadillac
    Join Date
    Mar 2008
    Location
    El Paso, Texas, United States
    Age
    42
    Posts
    240

    Re: *MY ISSUES* - Somebody shoot me.

    malfunction module

  5. #4
    xanax06's Avatar
    xanax06 is offline Cadillac Owners Fanatic
    Automobile(s): 1997 Catera
    Join Date
    Jan 2008
    Location
    Philadelphia
    Posts
    144

    Re: *MY ISSUES* - Somebody shoot me.

    Sounds like you have a short somewhere, I'd check the battery connections.
    Check for any loose wires. A bad battery can kill the alternator.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting