Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 6 of 6

Thread: I'm new and need help

  1. #1
    Join Date
    Apr 2004
    Posts
    9

    Question I'm new and need help

    I just bought my 00 Catera Sport with 52k on it and as I was driving it when I come to a stop or if I am just idling the oil pressure gauge goes all the way down to the middle of the red unless I keep my foot on the accelerator has anyone else had this problem or can anyone possibly help me, do you think Caddy will cover me under warranty??
    thanks

    I will be here alot!!!!!!!


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Vesicant's Avatar
    Vesicant is offline Cadillac Owners Connoisseur
    Automobile(s): None :(
    Join Date
    Nov 2003
    Location
    Jacksonville, FL
    Posts
    2,703

    Question Re: I'm new and need help

    When has it had its last oil change?

    The oil filter could be clogged up with junk, or maybe one of the passages is. How much oil is in it at the moment and what color is it? How high does the oil press get in the mornings when you first start the car up?

    Oh, and are there any oil lights actually comming on when it reaches into the red?


    Report with your findings if you would :coolgleam

  4. #3
    Join Date
    Apr 2004
    Posts
    9

    Re: I'm new and need help

    The oil is a darker golden brown and in the mornings the oil pressure seems to run fine for about fifteen minutes then it goes low again and yes the oil light comes on when it goes into the red and it beeps at me

    thanks

  5. #4
    Vesicant's Avatar
    Vesicant is offline Cadillac Owners Connoisseur
    Automobile(s): None :(
    Join Date
    Nov 2003
    Location
    Jacksonville, FL
    Posts
    2,703

    Re: I'm new and need help

    You could try first getting an oil change, that will replace the oil filter... which could be a cause. After that, its then a lame oil pump...

    Although, it could be other things; but it will require opening up the engine, and checking all the areas the oil flows through.

    The catera does have an oil to coolent oil cooler, and that could be on the fritz. If that seriously defects within a while, your going to be in a big world of trouble. (Oil in coolant is not good).

    Right now id say it could just be as simple as a clogged oil filter, ... then have a mechanic check the oil pump if it doesnt solve it. And if its not that, then .... oil cooler or somethings clogged internally.
    Last edited by Vesicant; 04-07-04 at 06:59 PM.

  6. #5
    Join Date
    Apr 2004
    Posts
    9

    Re: I'm new and need help

    Ok I will try that thanks, What oil does everyone run in their cateras

  7. #6
    Join Date
    Feb 2004
    Location
    Columbus, OH
    Age
    35
    Posts
    92

    Re: I'm new and need help

    I run Valvoline 5W30 fully synthetic and it seems to work great.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum