Flashing CEL and rough idle for appx 20 seconds
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 22
Cadillac Catera and Cimarron Forum Discussion, Flashing CEL and rough idle for appx 20 seconds in Past Cadillac Vehicle Discussion; I have a Check engine light, Dont know the code yet but I think its the P0411 returning. I got ...
  1. #1
    catera00's Avatar
    catera00 is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Feb 2007
    Location
    Tucson, Az
    Age
    38
    Posts
    390

    Flashing CEL and rough idle for appx 20 seconds

    I have a Check engine light, Dont know the code yet but I think its the P0411 returning. I got that code and had it reset at Autozone a week ago. I found a vacume hose near the brake booster w/ a slice in it and taped it up. Car was fine till yesterday. Now when I start the Car from a cold start, it idles rough, the rpms fluctuate from 1,000-1,200(ish) RPMs and the CEL flashes for about 20 seconds. Then the idle and RPMS smooth out and the CEL light stays on constant. The car is going to the dealer tomorrow but I wondered if anyone knew what that might be caused by. Thanks guys

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    9BlackN*Black6 is offline Cadillac Owners Fanatic
    Automobile(s): 96' Eldorado, 00' Volvo 770 N14+ 525HP
    Join Date
    Feb 2007
    Location
    Champaign, IL
    Posts
    154

    Re: Flashing CEL and rough idle for appx 20 seconds

    a flashing CEL is a missfire condition and usually sets a PO300, need a tune up? Over 100k miles?

  4. #3
    Marks DTM Calib is offline Cadillac Owners Fanatic
    Automobile(s): Vaux Omega (Caterra)
    Join Date
    Dec 2006
    Location
    Nottingham - England
    Posts
    235

    Re: Flashing CEL and rough idle for appx 20 seconds

    Check your hose repair first....the tape has probably come off when the engine got hot.....
    Note, the ECU one this power plant cant detect a missfire....

  5. #4
    PEETYZ's Avatar
    PEETYZ is offline Cadillac Owners Enthusiast
    Join Date
    May 2006
    Location
    Ohio
    Posts
    535

    Re: Flashing CEL and rough idle for appx 20 seconds

    my 98 catera manual in the U.S says when a check engine light is flashing a misfire in occuring and to shut car off and to see a dealer immediately is that not true?

  6. #5
    catera00's Avatar
    catera00 is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Feb 2007
    Location
    Tucson, Az
    Age
    38
    Posts
    390
    Thread Starter

    Re: Flashing CEL and rough idle for appx 20 seconds

    You guys are right, Misfire...

    okay, I took it to the dealer and my pass. side valve cover gasket was leaking oil into one or more cylinders (Typical prob for these cars I'm finding out) The repair was done free of charge since I just bought the car. The car still runs rough and lacks some power. After I got home, I went to the store and the check engine light came on again. Went to Autozone and read the codes. P0300, P0304, P0306- Misfires in cylinder 4 and 6

    4 and 6 are on the drivers side so I pulled those spark plugs and #6 was full of oil. Looks like the drivers side valve cover gasket is bad too. I cleaned the oil off the plugs and scuffed them with a wire brush. The car runs smooth now.
    So back to the shop it will be going. Thankfully I have a warranty that covers gaskets and seals. The dealer charges $396 to replace the covers. Yowza! They shoulda checked the other side while the plenum was off. Now they get to do it again.

    So the wierd thing is that when the engine ran crappy, it sounded like I had an exauhst leak. As soon as I cleaned the plugs, the sound went away.

    My car has 65K miles on it. How often do the valve cover gaskets go bad?

  7. #6
    Warez is offline Cadillac Owners Fanatic
    Join Date
    Jun 2005
    Posts
    484

    Re: Flashing CEL and rough idle for appx 20 seconds

    Quote Originally Posted by Marks DTM Calib View Post
    Check your hose repair first....the tape has probably come off when the engine got hot.....
    Note, the ECU one this power plant cant detect a missfire....
    They can indeed, and a flashing CEL spcifically indicates a misfire.

  8. #7
    catera00's Avatar
    catera00 is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Feb 2007
    Location
    Tucson, Az
    Age
    38
    Posts
    390
    Thread Starter

    Re: Flashing CEL and rough idle for appx 20 seconds

    Update**
    My issue continues.

    >>A little back ground: I just bought this car 3 weeks ago with 60k miles on it. I originally brought the car in to the dealer I bought it from because of the rough idle after cold start and check engine light. The found the passenger side valve cover was leaking oil. They fixed it free.. I got the car home and the next time I started it I had the rough idle and CEL again. I took it back in.<<

    The dealer replaced the coil pack. As Soon as I started the car, it ran rough and the check engine light came on again!!. Gave them the keys. They said it ran and started fine in the warm shop. Maybe the cold outdoors effect this prob.

    The car stayed for another day (3 days now)
    They had to get a fuel injector tester. They found on injector to be bad so they replaced it. Its fixed!!

    Until I got home and started it again later. Runs rough and guess what's blinking on the dash board... CHECK ENGINE!!

    Its going back on Monday.
    Is this a MAF prob? The technician mentioned there was a "stored code" mentioning the MAF. A lot of posts here with these exact symptoms, even the fact that other peoples cateras did this when it was cold and not when it was warm outside.

    If its the MAF, shouldn't they be seeing that when they are hooking the car up to their scanning machines?

    Thank goodness I've only paid for the coil pack so far.

    **Update**

    Went to Autozone and read the codes.
    I am getting the exact same codes, multiple missfire on cylinders 4 and 6
    Takin her back to the dealer Monday. I'll report back with more info. Any opinions on the MAF? Would that cause a misfire on specific cylinders? Its always 4 and 6

  9. #8
    catera00's Avatar
    catera00 is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Feb 2007
    Location
    Tucson, Az
    Age
    38
    Posts
    390
    Thread Starter

    Re: Flashing CEL and rough idle for appx 20 seconds

    I bought some CRC Mass Air Flow sensor cleaner. Using that made no difference. Dont think its the MAF. Any ideas?

  10. #9
    todd2fst4u's Avatar
    todd2fst4u is offline Cadillac Owners Fanatic
    Automobile(s): 1998 Catera
    Join Date
    Aug 2006
    Posts
    474

    Re: Flashing CEL and rough idle for appx 20 seconds

    Quote Originally Posted by catera00 View Post
    I bought some CRC Mass Air Flow sensor cleaner. Using that made no difference. Dont think its the MAF. Any ideas?
    if the MAF is faulty the cleaner isnt going to do anything anyway

  11. #10
    catera00's Avatar
    catera00 is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Feb 2007
    Location
    Tucson, Az
    Age
    38
    Posts
    390
    Thread Starter

    Re: Flashing CEL and rough idle for appx 20 seconds

    I went to the auto parts store to buy some coolant cause for some reason I am low. The coolant light came on yesterday. I have been noticing an odor coming from the car every time I park it. Its a kind of, hot smell. I assumed it was from the new valve cover gasket and other stuff they recently installed just getting hot and settling in so to speak. But the guy at the parts store said he smelled coolant. So we looked around and found no leaks. No puddles in my garage. He suggested maybe a head gasket is leaking into the #4 & 6 cylinders. I bet that would cause a misfire. I'll have the dealer do a compression test on the cylinders to check for a leaky head gasket.
    I'll have them test the MAF also.

  12. #11
    bengsxr is offline Cadillac Owners Fanatic
    Join Date
    Jun 2005
    Location
    Rochester, Minnsota
    Age
    34
    Posts
    190

    Re: Flashing CEL and rough idle for appx 20 seconds

    well you can always just unplug the mass air flow sensor to test it.

  13. #12
    catera00's Avatar
    catera00 is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Feb 2007
    Location
    Tucson, Az
    Age
    38
    Posts
    390
    Thread Starter

    Re: Flashing CEL and rough idle for appx 20 seconds

    Quote Originally Posted by bengsxr View Post
    well you can always just unplug the mass air flow sensor to test it.
    I did and it made no difference.

  14. #13
    catera00's Avatar
    catera00 is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Feb 2007
    Location
    Tucson, Az
    Age
    38
    Posts
    390
    Thread Starter

    Re: Flashing CEL and rough idle for appx 20 seconds

    I spoke to the dealer and they have no idea why its having this problem. I was affraid of that. Now that the weather has warmed up here the car is working good and the check engine light went away.

    I do have an exhaust leak at the exhaust donut. They suggested maybe it threw a false code because of that. (I doubt it)

    They are going to do a carbon cleaning on it. They are gonna (I assume) run something through the engine (Probably a fuel injector cleaner) in the hopes that theres a piece of carbon stuc somewhere. Sounds like they are grasping at straws at this point

  15. #14
    catera00's Avatar
    catera00 is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Feb 2007
    Location
    Tucson, Az
    Age
    38
    Posts
    390
    Thread Starter

    Re: Flashing CEL and rough idle for appx 20 seconds

    ok, heres the newest from the dealer:

    Compression test came back ok. No leaks.
    They are now getting an O2 sensor error

    I posted awhile back about a broken stud & bolt I found in the engine compartment:
    >>It has a triangle on the end of the stud

    Heres the back


    Side


    Looks like someone cross threaded it


    Heres where I found it. On the Pass. side


    Closer shot

    >>

    Well it seems that two of the studs that connect the header to the block broke. They say this is causing extra air enter the engine and cause the o2 sensor (Which is located after the header) to adjust the fuel mixture richer.

    So they are going to change the exhaust donut and replace the broken studs

    Holy crap man. Still havent made my first car payment! Hope this fixes it.
    Any thoughts?

  16. #15
    catera00's Avatar
    catera00 is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Feb 2007
    Location
    Tucson, Az
    Age
    38
    Posts
    390
    Thread Starter

    Re: Flashing CEL and rough idle for appx 20 seconds

    Well they finished with the exhaust leak and header studs. I went to pick it up. They test drove it 5 times that day. Then, just before I got there, the Service manager test drove it and guess what?
    Check engine light!!

    Left the there. Seriously, what the heck? Should I be concidering a different car? What could the problem be? The technician was going to test drive it with the scan tool connected. Who knows whats wrong with it....

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting