BLS 1.9 TiD saloon - various errors
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
Cadillac BLS Forum (Europe / South Africa) Discussion, BLS 1.9 TiD saloon - various errors in Past Cadillac Vehicle Discussion; Hello! I'm new to this forum but I've checked around a bit and thought I'd pop a question in, just ...
  1. #1
    BLS_1.9_TiD_Sweden is offline Cadillac Owners Member
    Automobile(s): BLS
    Join Date
    Jul 2010
    Posts
    11

    BLS 1.9 TiD saloon - various errors

    Hello!

    I'm new to this forum but I've checked around a bit and thought I'd pop a question in, just to see if anyone has the same problem as me.

    I have a 2006 (warranty start 200702) BLS 1.9 TiD saloon and sometimes I've seen some strange behavior. This comes and goes and some of the errors I've encountered in the on board computer are:
    - Anti skid regulation is inactive
    - ABS is inactive
    - Alarm is inactive
    - Rain sensors are inactive

    and a message telling me to contact my Cadillac workshop (or a Saab rather in my opionion).

    The ASR happend just yesterday. The problem is that the car is spotting me these errors from time to time, without any reason. Why I say without any reason is that this appears mostly when the car is just started or on my way somewhere. The ASR error occurred on the go, and a couple of minutes later, disappeared. The alarm and rain sensors hasn't been common, but at engine start, the message poped up on the display once or twice.

    My question is therefore, has anyone had this problem? If so, how was it fixed? If the car still was under warranty I wouldn't hesitate to take it to the workshop. My experience with the Swedish workshops is not positive in the Gothenburg area (Cadillac), thought I give a Saab workshop a try on the next service.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    S70RMP is offline Cadillac Owners Fanatic
    Automobile(s): BLS now gone RIP now Saab 9-3 Aero TTID Hirsch'd
    Join Date
    Sep 2008
    Location
    Manchester, UK
    Age
    45
    Posts
    370

    Re: BLS 1.9 TiD saloon - various errors

    sounds like you have some serious problems!

    I'd take it to a SAAB dealer

  4. #3
    BlackBox is offline Cadillac Owners Member
    Automobile(s): 2009er 2.0 T FlexFuel Waggon
    Join Date
    Mar 2010
    Location
    Germany
    Posts
    24

    Re: BLS 1.9 TiD saloon - various errors



    Sounds expensive!

    Seems to be the best way to drive to a mechanik and let them check.

    Good Luck

    Thorsten

  5. #4
    bigcul1's Avatar
    bigcul1 is offline Cadillac Owners Member
    Automobile(s): BLS 1.9TID
    Join Date
    Feb 2010
    Location
    Durham
    Age
    34
    Posts
    47

    Re: BLS 1.9 TiD saloon - various errors

    You may not be able to take it to a SAAB engineers. If it has to go on the Tech 2 diagnostic machine some codes etc are specific to Cadillac and wont be read properly under SAAB tech 2 equipment. I would reset everything first before thinking of going to a garage, try disconnecting the battery for 10 mins then connecting it back up. This should reset the system. Then drive for a while and see if the problems crop up again. These Cadillacs are extremely sensitive to sensor conditions. If the problems persist I would get it to the Cadillac Dealers and get tech 2 to diagnose the problem.

  6. #5
    BLS_1.9_TiD_Sweden is offline Cadillac Owners Member
    Automobile(s): BLS
    Join Date
    Jul 2010
    Posts
    11

    Re: BLS 1.9 TiD saloon - various errors

    Hello bigcul1 and sorry for the ultra-delay on replying.

    I tried what you did (almost 1.5 years ago...) and it worked just great! All errors that I had went away and I haven't had any error messages since then Thanks alot guys, wasn't such a big problem after all. Also, I took the car to my mechanics at my new job, they hooked it up and didn't see any codes of error. I guess it was a hick-up.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting