Sound System Not Working Right, Need Help
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 21
Cadillac Audio, Video and Security Systems Discussion, Sound System Not Working Right, Need Help in Item Specific Cadillac Discussion; recently, my sound system (2 15" Blitz subwoofers with 1000 watt kenwood amp) started shorting out and eventually stopped completely. ...
  1. #1
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Sound System Not Working Right, Need Help

    recently, my sound system (2 15" Blitz subwoofers with 1000 watt kenwood amp) started shorting out and eventually stopped completely. I took it to my sterio shop and they made me upgrade to a thicker power wire which I should of done when I upgraded from 12 to 15" subwoofers. It worked much better and hit much harder after they replaced the wire, but it is still partially shorting out. the subs will just stop working for a few secs during a song then start again. Does anyone know why they are doing this?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    thewireman* is offline Cadillac Owners Fanatic
    Automobile(s): 99 Cadillac Deville
    Join Date
    Feb 2008
    Location
    Paw Paw, MI
    Posts
    139

    Re: Sound System Not Working Right, Need Help

    Well, Does your amp go to protect mode everytime it starting to stop? Another thing I would check is the RCA's, they can go bad, Check for the ground, make sure you sand the paint off and insure a good ground. Ground is very important.

  4. #3
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by thewireman* View Post
    Well, Does your amp go to protect mode everytime it starting to stop? Another thing I would check is the RCA's, they can go bad, Check for the ground, make sure you sand the paint off and insure a good ground. Ground is very important.
    Im not sure, im thinking it might be the amp going bad or something. What are RCA's?

  5. #4
    91sonomast's Avatar
    91sonomast is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac
    Join Date
    Feb 2008
    Location
    FL
    Posts
    100

    Re: Sound System Not Working Right, Need Help

    o man, you know nothing about stereos i assume?
    what it sounds like is your amp is starving for power and goes into protect mode which cuts power internally so it wont short out the circuitry in the amp. what you need is a bigger power wire my friend. what size power and ground wire do you have?

  6. #5
    thewireman* is offline Cadillac Owners Fanatic
    Automobile(s): 99 Cadillac Deville
    Join Date
    Feb 2008
    Location
    Paw Paw, MI
    Posts
    139

    Re: Sound System Not Working Right, Need Help

    RCA will look like this,

    Unless you have it hooked up with your factory speaker wires. (high frequency connections)

  7. #6
    thewireman* is offline Cadillac Owners Fanatic
    Automobile(s): 99 Cadillac Deville
    Join Date
    Feb 2008
    Location
    Paw Paw, MI
    Posts
    139

    Re: Sound System Not Working Right, Need Help

    He said he already upgraded the wire.

  8. #7
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by 91sonomast View Post
    o man, you know nothing about stereos i assume?
    what it sounds like is your amp is starving for power and goes into protect mode which cuts power internally so it wont short out the circuitry in the amp. what you need is a bigger power wire my friend. what size power and ground wire do you have?
    but I just upgraded to a thicker wire, im sure the sterio shop knows what they are talking about. switching the wire did make it work much better, but it still messes up a little. and I had the 15's with the smaller wire for months before I had any problems. could it be a loose connection or something? or is this a battery problem? don't know the sizes of the wire, but I saw that it was thick.

  9. #8
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by thewireman* View Post
    RCA will look like this,

    Unless you have it hooked up with your factory speaker wires. (high frequency connections)
    I don't think there are any RCA connections then. Im not exactly sure how it is wired. I think the system might be connected to the stock subwoofer, and there is a sterio wire under my hood, near the fuse box. I also have the factory sterio and speakers.

  10. #9
    91sonomast's Avatar
    91sonomast is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac
    Join Date
    Feb 2008
    Location
    FL
    Posts
    100

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by thewireman* View Post
    He said he already upgraded the wire.
    doesnt mean they went big enough. They could have gone from 10ga. to 8ga. and not everyone is as honest as we would like them to be unfortunately. sounds kind of like a loose connection possibly, but i still say its not getting enough power.

  11. #10
    thewireman* is offline Cadillac Owners Fanatic
    Automobile(s): 99 Cadillac Deville
    Join Date
    Feb 2008
    Location
    Paw Paw, MI
    Posts
    139

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by 91sonomast View Post
    doesnt mean they went big enough. They could have gone from 10ga. to 8ga. and not everyone is as honest as we would like them to be unfortunately. sounds kind of like a loose connection possibly, but i still say its not getting enough power.
    You have a point, and I agree with you, but I figure the Audio Shop should know better, the correct wire size. But now he is saying that he don't think he has RCA hooked to it. Hmmm..

    Cadillac_pimpz, Could you take pictures of your amp hook up, and read the number on the wire? It should say, 8 gauge, 4 gauge, 0 gauge, etc. We need more info. Thanks.

  12. #11
    91sonomast's Avatar
    91sonomast is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac
    Join Date
    Feb 2008
    Location
    FL
    Posts
    100

    Re: Sound System Not Working Right, Need Help

    im having the same issue when im really beating my subs, my amp isnt getting enough power and shuts off. im running 4ga from battery to dist block, then 8 ga to mids and highs amp, and to my sub amp, im going to have to run 4ga to the subs amp for now. when i get a new vehicle in the next few months it will be wired with 0ga. that way i have plenty of power lol.

  13. #12
    thewireman* is offline Cadillac Owners Fanatic
    Automobile(s): 99 Cadillac Deville
    Join Date
    Feb 2008
    Location
    Paw Paw, MI
    Posts
    139

    Re: Sound System Not Working Right, Need Help

    Oh yeah, Thats what I have. With a Cap (I use Batcap) helps even better. I have dual Battery with 200 Amp Alternator to help feed the juice my two amps hooked to my one (yes one) 12" Pioneer Premier sub. Sounds amazing.

  14. #13
    thewireman* is offline Cadillac Owners Fanatic
    Automobile(s): 99 Cadillac Deville
    Join Date
    Feb 2008
    Location
    Paw Paw, MI
    Posts
    139

    Re: Sound System Not Working Right, Need Help

    Does anybody know where I could get dual alternator setup kit for 1999 Deville? It would help a lot! LOL

  15. #14
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by 91sonomast View Post
    doesnt mean they went big enough. They could have gone from 10ga. to 8ga. and not everyone is as honest as we would like them to be unfortunately. sounds kind of like a loose connection possibly, but i still say its not getting enough power.
    so your final guess is that I need bigger wire?

  16. #15
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by 91sonomast View Post
    im having the same issue when im really beating my subs, my amp isnt getting enough power and shuts off. im running 4ga from battery to dist block, then 8 ga to mids and highs amp, and to my sub amp, im going to have to run 4ga to the subs amp for now. when i get a new vehicle in the next few months it will be wired with 0ga. that way i have plenty of power lol.
    My system is definately more powerful now that is has that thicker wire. I set off my first car alarm today. hahaha

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting