Sound System Not Working Right, Need Help - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 21 of 21
Cadillac Audio, Video and Security Systems Discussion, Sound System Not Working Right, Need Help in Item Specific Cadillac Discussion; Originally Posted by cadillac_pimpz My system is definately more powerful now that is has that thicker wire. I set off ...
  1. #16
    thewireman* is offline Cadillac Owners Fanatic
    Automobile(s): 99 Cadillac Deville
    Join Date
    Feb 2008
    Location
    Paw Paw, MI
    Posts
    139

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by cadillac_pimpz View Post
    My system is definately more powerful now that is has that thicker wire. I set off my first car alarm today. hahaha
    So you don't have any problems now?

  2. #17
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by thewireman* View Post
    So you don't have any problems now?
    I didn't notice any today, but there have still been problems since I upgraded the wire. I just tooks some pics of the wires.
    Attached Images

  3. #18
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by thewireman* View Post
    RCA will look like this,

    Unless you have it hooked up with your factory speaker wires. (high frequency connections)
    You were right, it does have RCA connections on the amp, I just never noticed it before.

  4. #19
    thewireman* is offline Cadillac Owners Fanatic
    Automobile(s): 99 Cadillac Deville
    Join Date
    Feb 2008
    Location
    Paw Paw, MI
    Posts
    139

    Re: Sound System Not Working Right, Need Help

    WOW the pictures helps a lot! Well, you have 4 gauge wire. Your Kenwood handles 1000 watts PEAK right? Is it class D? So it would be 500 watts RMS. That should be big enough for your amp. But do you notice any of your lights dimming when you play at high volumes? A cap will fix it. But if your having problems with your system again, I would try a better, durable RCAs. Because from the picture I've seen, the RCAs are bent pretty good and can wear off. You should give a little room play. Here try this, when playing a CD, jiggle the RCA area and see if stops playing music. If it does, its the RCAs.

  5. #20
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Re: Sound System Not Working Right, Need Help

    Quote Originally Posted by thewireman* View Post
    WOW the pictures helps a lot! Well, you have 4 gauge wire. Your Kenwood handles 1000 watts PEAK right? Is it class D? So it would be 500 watts RMS. That should be big enough for your amp. But do you notice any of your lights dimming when you play at high volumes? A cap will fix it. But if your having problems with your system again, I would try a better, durable RCAs. Because from the picture I've seen, the RCAs are bent pretty good and can wear off. You should give a little room play. Here try this, when playing a CD, jiggle the RCA area and see if stops playing music. If it does, its the RCAs.
    yep, 1000 watt amp. Class D? what is being rated by class, the amp? The lights don't dim. Can't play cd's, have the stock cassette radio, but I just use my ipod with a cassette converter which works fine. Although I have a cd changer...not in my car, I wouldn't be able to put it in my trunk anyway would I? I hear that the magnets in the subs destroy cd's.

  6. #21
    cadillac_pimpz's Avatar
    cadillac_pimpz is offline Cadillac Owners Fanatic
    Automobile(s): Custom 2005 Cadillac Deville, Pimp Edition
    Join Date
    Mar 2007
    Location
    Dallas, TX
    Age
    25
    Posts
    275

    Re: Sound System Not Working Right, Need Help

    so it turns out that the problem was that with the new power wire, the subs couldn't handle that much power and got fried. so I bought 2 15" JBL GT150d subwoofers to replace them. Although they are being a little glitchy. they are not starting when I turn my car on, so I will have to restart my car to get them to work.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting