Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 34
Cadillac Audio, Video and Security Systems Discussion, Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar. in Item Specific Cadillac Discussion; Well..............today the radio turned off/lost power three times while i was driving (all with in 15 minutes), and the day ...
  1. #1
    mrgoodbar67's Avatar
    mrgoodbar67 is offline Cadillac Owners Enthusiast
    Automobile(s): 2002 Cadillac DTS Deville on Vogues and DTS Blades
    Join Date
    Jul 2007
    Location
    Bell, CA
    Age
    30
    Posts
    605

    Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    Well..............today the radio turned off/lost power three times while i was driving (all with in 15 minutes), and the day isnt even over!!!!!!!!!!!!!! It came back each time on after a couple seconds.

    This weekend im going to pull that thing out and go over every single part of the install and check every wire connecter for faulty connections. Im also going to connect the mute, brake, back up, and vss as the interface said, just to do it by the book.

    Im also going to try and hook up the ILL wire directly to the headlight switch wire because currently the map does not go to night mode when my heads are on. And yes, i did connect the pionner ILL wire to the os06 interface but still does not work.
    Ive been told its a brown wire under that switches to 12v when lights are on. Does anyone know how to go about it on a 02 deville?

    Also I hate it that the back up beeps dont come on like they used to. Now you only hear them sometimes, and even then, it cuts off the stereo sound to allow the beeps to come through. Not very consistent at all.
    I cant even hear the beeps when i press driver seat settings 1 or 2.

    These things are really annoying me man!
    Ive been told that this problem are caused becasue of the programming on the os06.

    If someone has had these problems b4, please help me out. I dont wanna hook up the stock stereo in the trunk either b/c i was told that GMOS06 would work.

    Thanks in advance for your help.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    CadillacSTS42005's Avatar
    CadillacSTS42005 is offline Banned
    Automobile(s): 2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
    Join Date
    Oct 2005
    Posts
    15,992

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    before i go into anything im gonna wait till you check the wires and ensure the connections are correct
    i think connecting and tieing more into the GMOS-06 will only create more problems but i suppose its worth a shot
    oh and i PRAY to god you used wire crimps and not just electrical tape...

  4. #3
    mrgoodbar67's Avatar
    mrgoodbar67 is offline Cadillac Owners Enthusiast
    Automobile(s): 2002 Cadillac DTS Deville on Vogues and DTS Blades
    Join Date
    Jul 2007
    Location
    Bell, CA
    Age
    30
    Posts
    605
    Thread Starter

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    What Are Crimps?
    Actually, I Used Scotch Tape. It Works Well With Everything Because Its Transparent....... Hahahahahahahaha!!!

    Of Coarse I Used Wire Crimps.
    My Pops Was A Badass Electrician And He Taught Me A Bit About Electricity Before He Passsed Away On 06/10.
    Auto Electronics And House Hold Electroincs Might Not Be Exactly The Same But I Know The Basics.
    Shit, I Already Had All The Neccassary Tools For Instal (wire Cutters, Strippers, Connecters, Wires, Etc...)

    As For The Solutions. I Hope I Can Solve It All This Weekend.
    Ill Keep You Posted.

  5. #4
    CadillacSTS42005's Avatar
    CadillacSTS42005 is offline Banned
    Automobile(s): 2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
    Join Date
    Oct 2005
    Posts
    15,992

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    lol
    had me scared for a minute there

    home and auto is essentially the same except for current (the whole a/c d/c thing and im not talking about the band...)

    you should SEE some of the hack jobs ive seen at Best Buy (not done by us, but people have brought to us for diagnostics)

    for example a guy came in complaining his stereo kept shutting off as he went over a bump

    i checked the ground, ok seems good, then i trace his power wire, which has been run with (i bs you not) a telephone cord through a hole in the firewall which must have been made with a hammar and a nail with nothing to cover the rough edges
    the wire stripped itself on the edges and kept grounding itself off the firewall!

  6. #5
    mrgoodbar67's Avatar
    mrgoodbar67 is offline Cadillac Owners Enthusiast
    Automobile(s): 2002 Cadillac DTS Deville on Vogues and DTS Blades
    Join Date
    Jul 2007
    Location
    Bell, CA
    Age
    30
    Posts
    605
    Thread Starter

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    ok good news...sort of.
    i checked the connections, and recrimmped some just to be sure.
    the beeps are not as consistent as a wish they were, but got better.

    while i was driving, the unit turned off once today. that was it. then turned back on after like 10 secs...so i still need help in this area. i connected the backup lead to the avic power harness but not to the back up lights yet...its just hanging in the trunk.
    do you think thats what is causing the unit to power down suddenly. maybe it grounds itself like you mentioned earlier. let me know any ideas.

    now, the onstar problem i had regarding the screen is fixed so that solves that.

    i couldnt get the unit as flush as i thought it would go. dont know why, the stock nav and avic d3 seem to have the same depth............so i left it as is. i dont wanna cut anymore plastic than i had to. plus if i wanna get it in deeper i would have to cut steel and i dont wanna do that.
    so i guess im happy....except for the power thing.

  7. #6
    mrgoodbar67's Avatar
    mrgoodbar67 is offline Cadillac Owners Enthusiast
    Automobile(s): 2002 Cadillac DTS Deville on Vogues and DTS Blades
    Join Date
    Jul 2007
    Location
    Bell, CA
    Age
    30
    Posts
    605
    Thread Starter

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    oh and the ill does not automatically turn to night mode so i still gotta rerout that wire to the headlights.
    do you know wher the easiest place would be?

  8. #7
    CadillacSTS42005's Avatar
    CadillacSTS42005 is offline Banned
    Automobile(s): 2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
    Join Date
    Oct 2005
    Posts
    15,992

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    def not the problem
    its gotta be an ignition issue through the data bus...

  9. #8
    mrgoodbar67's Avatar
    mrgoodbar67 is offline Cadillac Owners Enthusiast
    Automobile(s): 2002 Cadillac DTS Deville on Vogues and DTS Blades
    Join Date
    Jul 2007
    Location
    Bell, CA
    Age
    30
    Posts
    605
    Thread Starter

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    While I Was Recrimmping, I Redid The Power Wires And The Acc 12v Wires. So I Know Those Connections Are Solid.

    The Power Off Thing Does Not Happen On Bumps, Etc.....it Happens Whenever, Whereever I Guess, No Way Of Knowing When It Will Happen.

    The Unit Just Shuts Off, As If The Car Is Off, And Then Powers Back On After A Couple Secs. No Presets Are Reset.

    Are You Saying I Got A Faulty Gmos06? I Was Told That Somewhere Else.

  10. #9
    CadillacSTS42005's Avatar
    CadillacSTS42005 is offline Banned
    Automobile(s): 2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
    Join Date
    Oct 2005
    Posts
    15,992

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    no
    what im saying is it car or the 06 is cutting ign power not a bad connection

    try this

    keep everything connected as it is but ALSO add an ignition power wire directly from the plug bypassing the 06 directly to the D3

    let me know what happens

  11. #10
    mrgoodbar67's Avatar
    mrgoodbar67 is offline Cadillac Owners Enthusiast
    Automobile(s): 2002 Cadillac DTS Deville on Vogues and DTS Blades
    Join Date
    Jul 2007
    Location
    Bell, CA
    Age
    30
    Posts
    605
    Thread Starter

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    Ok ill try that soon. ill let you know what happens with the powere issue. maybe this week.

    Meanwhile....besides the power issue, which you know about already, everything works fine.....except for illimination/dim!!!!!!!!!!!!!!!!

    i hooked up the d3's orange/white ill wire to the orange/white ill wire on the gmos06 but it doesnt work.

    help me find another way to have the ill/dim night function work properly on my d3.

    i searched for solutions on an avic forum but found none for an 02 deville specific.
    closest i got was gm vehicles like trailblazers, pontiacs, etc...

    so i applied their solutions which consists of hooking up the d3 ill (orange/white) wire to headlight control (brown) wire to let the unit know when the lights are on and make it go into nightmode. made sense so i decided to try it.

    as you know, i have auto headlights (with manual turn-on option) and daytime running lights

    when i connected them i saw that the screen did dim. when i pressed map, the map did look darker. not a black map.....more like gray.
    Is that right?

    anyways, the problem i have now is that when the knob i set to headlights "OFF", the screen dims and the map goes into night mode.
    And when i manually turn the lights "ON" the map goes into day mode and the screen brightens up.
    isnt it supposed to be vice versa?
    the autolights turn-on/off switch has no effect on the dim/nightmode feature either.

    please help, this is annoying at night?

    Perfect operations would be-
    At night----->Headlights turn on (either manually or autmatically)----->D3 screen dims and goes into night mode.
    During day----->Headlights off (either manually or autmatically)----->D3 brightens up and goes into daymode.

    it used to do this when i had the stock DENSO cadi navigation........

    help me make this happen with the d3.
    thanks

  12. #11
    CadillacSTS42005's Avatar
    CadillacSTS42005 is offline Banned
    Automobile(s): 2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
    Join Date
    Oct 2005
    Posts
    15,992

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    the D3 itself has a Day, Night and Auto Mode....
    are you sure your not in Day?

  13. #12
    mrgoodbar67's Avatar
    mrgoodbar67 is offline Cadillac Owners Enthusiast
    Automobile(s): 2002 Cadillac DTS Deville on Vogues and DTS Blades
    Join Date
    Jul 2007
    Location
    Bell, CA
    Age
    30
    Posts
    605
    Thread Starter

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    Nope.
    I go to the map--->menu--->map display options---> and then it has a touch button that reads "Daymode/Nightmode"---> if i press it, it changes from daytime or nighttime or vice versa.
    No "Auto" option at all.
    just Nighttime and Daytime.

  14. #13
    CadillacSTS42005's Avatar
    CadillacSTS42005 is offline Banned
    Automobile(s): 2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
    Join Date
    Oct 2005
    Posts
    15,992

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    huh i swear it had an auto button (been awhile since i played with the D3 at work)

    now heres what we need to do

    when you pull the radio next time check to see if when you turn your lights on if the Orange wire (not at the radio, at the harness) is live or dead

    that will allow us to figure out if its a radio problem or if in fact the wire isnt properly fed

    if memory serves me right the harness on the nav system radios have the dimmer wire in a different location and when i did my nav install i had to eliminate it as if left there it would actually blow the illumination fuse

  15. #14
    CadillacSTS42005's Avatar
    CadillacSTS42005 is offline Banned
    Automobile(s): 2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
    Join Date
    Oct 2005
    Posts
    15,992

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    found it
    thats EXACTLY why it wont work
    factory nav cars DO NOT have an illumination wire in pin E5 (which is where the illumination wire is on non navs) they IN FACT have a bare ground wire

    if you want it to work youll need to tap into the backlight wire at the a/c controls.



    i highlighted the wire your looking for in RED

    that will fix your backlight problem IM POSITIVE!

  16. #15
    mrgoodbar67's Avatar
    mrgoodbar67 is offline Cadillac Owners Enthusiast
    Automobile(s): 2002 Cadillac DTS Deville on Vogues and DTS Blades
    Join Date
    Jul 2007
    Location
    Bell, CA
    Age
    30
    Posts
    605
    Thread Starter

    Re: Problems w/GMOS06 & Avic D3 in 02 dev w/bose & onstar.

    Wow sure sounds like my problem bro.
    and you just gave me the solution.
    Thanks ill see what happens.
    youre a GOD......well, not really, but almost.
    keep you posted.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting