Cold start misfire issues
cadillac ats forums cadillac ats forums
CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
Like Tree1Likes
  • 2 Post By Cadillac Cust Svc
Cadillac ATS General Discussion Forum Discussion, Cold start misfire issues in Cadillac ATS Discussion Forums; I recently got my ATS and the 1st night I had it going home the service engine light flashed and ...
  1. #1
    Last of a Breed is offline Cadillac Owners Member
    Join Date
    Jun 2012
    Age
    33
    Posts
    13

    Cold start misfire issues

    I recently got my ATS and the 1st night I had it going home the service engine light flashed and then stayed on. I brought it in to get looked at, and they code was a cold start mid fire. The dealer did a compression check on the engine and everything checked out. On the way home today, the light again flashed intermittently for about 15 seconds. Any one else have this issue? I'm a little upset a brand new car already has potential engine problems. Could it be a PCM issue?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    hood101010 is offline Cadillac Owners Fanatic
    Automobile(s): 2013 Cadillac ATS 3.6 Performance
    Join Date
    Apr 2012
    Location
    Tampa , FL
    Posts
    154

    Re: Cold start misfire issues

    I too had a check engine light in the first week. I had a very rough idle and light would come on either right at start or when I got on the gas pedal pretty heavy. took it in for service and they said it was a loose connection where a sensor snapped into the MAF sensor. They "modified" the connector. No problems since. If the sensor was loose why did the have to modify the connector. Sounded more like a defect.

  4. #3
    investor74 is offline Cadillac Owners Enthusiast
    Automobile(s): '97 Forest Green Catera
    Join Date
    Nov 2005
    Posts
    665

    Re: Cold start misfire issues

    Which engine do you have?

  5. #4
    Cadillac Cust Svc's Avatar
    Cadillac Cust Svc is offline Cadillac Customer Service
    Automobile(s): All Cadillac vehicles!
    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    11,337

    Re: Cold start misfire issues

    Quote Originally Posted by Last of a Breed View Post
    I recently got my ATS and the 1st night I had it going home the service engine light flashed and then stayed on. I brought it in to get looked at, and they code was a cold start mid fire. The dealer did a compression check on the engine and everything checked out. On the way home today, the light again flashed intermittently for about 15 seconds. Any one else have this issue? I'm a little upset a brand new car already has potential engine problems. Could it be a PCM issue?
    Last of a Breed, I'm very sorry to hear about this frustration, especially so shortly after purchase! I do recommend bringing your ATS back to your dealer if this continues, and please don't hesitate to contact me if you would like me to investigate further for you or contact your dealer on your behalf. I'm reachable via email at Katie_Lucille@gmexpert.com for further assistance.

    Quote Originally Posted by hood101010 View Post
    I too had a check engine light in the first week. I had a very rough idle and light would come on either right at start or when I got on the gas pedal pretty heavy. took it in for service and they said it was a loose connection where a sensor snapped into the MAF sensor. They "modified" the connector. No problems since. If the sensor was loose why did the have to modify the connector. Sounded more like a defect.
    Hood, I just wanted to thank you for sharing what appears to have resolved the concern for you. If you have any related questions you would like me to investigate, please contact me anytime. Meanwhile, I will be sure to document your feedback where the appropriate GM teams can view it!

    Best,

    Katie
    Cadillac Customer Service
    jamboarder and jamboarder like this.

  6. #5
    Last of a Breed is offline Cadillac Owners Member
    Join Date
    Jun 2012
    Age
    33
    Posts
    13

    Re: Cold start misfire issues

    Thanks Katie. It happened again on the way home today so I will be calling the dealership again. We'll see what what happens. I'm definitely not happy about it. This is my 1st Cadillac and this has soured my experience.

  7. #6
    Cadillac Cust Svc's Avatar
    Cadillac Cust Svc is offline Cadillac Customer Service
    Automobile(s): All Cadillac vehicles!
    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    11,337

    Re: Cold start misfire issues

    I can understand your perspective on this, Last of a Breed. You don't expect multiple dealer trips after purchasing a new vehicle. I am, however, glad to hear your dealer's specialized technicians will be running the proper diagnostic tests on it and documenting your concerns.

    Thank you for keeping us posted, and if you do have any concerns after consulting with your dealership, then I'm available to work towards a resolution with you!

    Katie
    Cadillac Customer Service

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting