Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 4 of 4

Thread: 1993 Allante speedometer problem

  1. #1
    giants1954 is offline Cadillac Owners Member
    Automobile(s): allante
    Join Date
    May 2011
    Posts
    2

    1993 Allante speedometer problem

    Hello Guys---

    Have a 93 Allante with analog instruments. Battery went bad during the winter-60 months exact--tried to start---I think low voltage caused a problem with the speedometer--it went from 0-140 MPH and pegged itself and has stayed there.
    Replaced the battery--everything seems to work perfect--but the speedo is pegged and does not move--ignition on or off.

    Hopeing the wisdom of the group can help.---Ray


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    D Yaros's Avatar
    D Yaros is offline Cadillac Owners Fanatic
    Automobile(s): 1955 CDV, 1992 Allante, 1962 Olds 88 Conv
    Join Date
    Nov 2009
    Location
    Milwaukee
    Posts
    182

    Re: 1993 Allante speedometer problem

    I am having a little trouble wrapping my head around this one. If it is an analog dash, the speedo should be mechanical, not electrical. I cannot comprehend how changing the battery here would case the needle to peg out at 140 MPH? May sound dumb, but have you tried tapping on the speedometer cluster?

  4. #3
    giants1954 is offline Cadillac Owners Member
    Automobile(s): allante
    Join Date
    May 2011
    Posts
    2

    Re: 1993 Allante speedometer problem

    An electrical pulse sending unit at the tranny sens pulses to the speedo. Yes--I tried tapping on the cluster to no avail. But--we all get lucky once in a while. I decided to do another road test and try the cruise control for confirmation of failure. I didn't expect it to work but nothing ventured? Set up at aprox 40 MPH and voilla--the cruise engaged-but still 155 MPH on the speedo. Decided to accelerate the cruise to see what happens? At about 55 MPH--the speedo suddenly dropped to 55 MPH and has acted normally the rest of the test drive. Did a shut down -and started up-all good! Thanks so much for just offering an idea----Ray

  5. #4
    D Yaros's Avatar
    D Yaros is offline Cadillac Owners Fanatic
    Automobile(s): 1955 CDV, 1992 Allante, 1962 Olds 88 Conv
    Join Date
    Nov 2009
    Location
    Milwaukee
    Posts
    182

    Re: 1993 Allante speedometer problem

    Glad you found a solution. Great improvisation/thinking on your part!


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum