radio comes on but no sound "system fault"
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
Cadillac Allante Forum Discussion, radio comes on but no sound "system fault" in Past Cadillac Vehicle Discussion; Good day. Ok I fell asleep and we had a downpouring rain THE TOP WAS DOWN !. The car seemed ...
  1. #1
    renob1995 is offline Cadillac Owners Member
    Automobile(s): allante
    Join Date
    Apr 2010
    Age
    52
    Posts
    6

    radio comes on but no sound "system fault"

    Good day.

    Ok I fell asleep and we had a downpouring rain THE TOP WAS DOWN !. The car seemed ok (no problems). So I cleaned all the water out and two days later when I started up my 93 allante the console displayed "System Fault". But she started up. then would not start up. Waited a few minutes then started up again but still system fault. I opened up the fuse/ battery panel and yep water. So I cleaned it out as best I can. Re started her up everything was ok except radio comes on but no sound thru speakers .

    1. Would this be a fuse issue ?.
    2. If so then which one.
    3. How can I get a manual since I don't have one .
    4. Any suggestions as to what the problem might be ?.

    HELP


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Ieradi's Avatar
    Ieradi is offline Cadillac Owners Fanatic
    Automobile(s): 1992 Allante
    Join Date
    Oct 2007
    Location
    Media, PA outside of Philadelp
    Age
    54
    Posts
    231

    Re: radio comes on but no sound "system fault"

    Quote Originally Posted by renob1995 View Post
    Good day.

    Ok I fell asleep and we had a downpouring rain THE TOP WAS DOWN !. The car seemed ok (no problems). So I cleaned all the water out and two days later when I started up my 93 allante the console displayed "System Fault". But she started up. then would not start up. Waited a few minutes then started up again but still system fault. I opened up the fuse/ battery panel and yep water. So I cleaned it out as best I can. Re started her up everything was ok except radio comes on but no sound thru speakers .

    1. Would this be a fuse issue ?.
    2. If so then which one.
    3. How can I get a manual since I don't have one .
    4. Any suggestions as to what the problem might be ?.

    HELP
    Word for the wise - if that ever happens again IMMEDIATLEY DISCONNECT THE BATTERY then start to dry where possible and allow to air dry for a few days before trying to start.

    I'm not certain for the 93 as I believe it is different than my 92. You can search on google or here for fuse locations. I did that before I managed to get a manual for my 90.

  4. #3
    wcoates is offline Cadillac Owners Fanatic
    Automobile(s): 1989 Red Allante,
    Join Date
    Nov 2005
    Location
    Canfield Ohio
    Posts
    313

    Re: radio comes on but no sound "system fault"

    Tony as the most recent ADAOTM award winner on the "other site" (I am a multiple winner unfortunately) I think you should invite him to participate.

  5. Remove Advertisements
    Cadillac Forums
    Advertisements
     

  6. #4
    Ieradi's Avatar
    Ieradi is offline Cadillac Owners Fanatic
    Automobile(s): 1992 Allante
    Join Date
    Oct 2007
    Location
    Media, PA outside of Philadelp
    Age
    54
    Posts
    231

    Re: radio comes on but no sound "system fault"

    RENOB1995 - As owners of these fine, complicated automobiles, more information is better! I sent you a Private Message with a link to more information. There is a cross section of guys and gals that span both sites.

    Regards - Tony

  7. Remove Advertisements
    Cadillac Forums
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •