How can I get this beauty running sweet again??
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
500, 472, 425, 368 Discussion, How can I get this beauty running sweet again?? in Cadillac Engine Technical Discussion; Hi. I'm new to the forum and Cadillac ownership (loving it .....!) I recently purchased a very good condition 1969 ...
  1. #1
    69DVC's Avatar
    69DVC is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Oct 2006
    Location
    Dublin, Ireland
    Posts
    92

    How can I get this beauty running sweet again??

    Hi.

    I'm new to the forum and Cadillac ownership (loving it .....!)

    I recently purchased a very good condition 1969 Deville convertible in yellow with a black top. (basically my dream car, I've always wanted a nice 472 convertible)

    The car is in really good driver condition - rot free underbody, only very small areas of rust & a slightly sagging drivers door.

    Only problem is the car has NO history. So I know nothing about it only it was left sitting for a year before I drove it home(300 miles)- unavoidable unfortunately.

    There are a couple of issues regarding the engine / electrics.

    It was converted some years ago (early '90's) to a LPG(propane) / gasoline dual fuel switchable setup. Basically a large tank in the trunk, electric fuel pump and a mixer to supply propane to the carb. I am concentrating on getting it running on gas well, before I deal with the dual fuel setup.

    Apart from this I believe the engine is stock.

    The car ran fine on the drive back apart from bad gas mileage (5-6 mpg) and it also bogged down then stalled on the freeway (so scary.... about five separate times. but would start back up after a few mins. while it would stall I heard a loud tick tick sound coming from the electric fuel pump.

    Since then, I have changed the oil, dist cap, rotor, plugs and wires.

    More recently, the car hard to start when cold (3-4 cranks) and spits out black soot on startup (and for a few mins after) and will stall 3 times until driven a short distance. Has a rough / shaky idle also when warm and sometimes bogs/sounds very rough on WOT. It also stinks of raw gas (not nice with the top down)

    Took it to a carb place for a tune-up (no real improvement in running) and they said, they have left it on the rich side (!) to counteract a slight miss. Which could be electrically caused. It's possible the carb shop guy doesn't know about quadrajets and it just needs a rebuild...

    I have also noticed that if the engine is off the wipers / top will only work very slowly then stop soon after. I'm wondering if the poor running is caused by electrics, and the gen light doesn't stay on, what other electrical parts could cause this ?

    Apols for the long post......can anyone help me get this old bruiser back to form ?

    Jon.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    jk1000 is offline Cadillac Owners Member
    Join Date
    May 2004
    Location
    tx
    Posts
    90

    Re: How can I get this beauty running sweet again??

    Electric fuel pumps and carbs do not mix well. The rochester can only handle 5 psi of fuel pressure. Higher pressures will cause the needle valve to be lifted off its seat. Result---very rich running and stalling.

    Your options are 1.) ditch the electric pump and go back to a mechanical, or 2.) get a fuel pressure regulator.

  4. #3
    The Ape Man's Avatar
    The Ape Man is offline Cadillac Owners Connoisseur
    Automobile(s): '80 Fleetwood Coupe, 1994 and 1995 Mercedes 140 Coupe
    Join Date
    Feb 2005
    Location
    Southern NJ
    Age
    52
    Posts
    2,096

    Re: How can I get this beauty running sweet again??

    Take a good look inside the distributor and make sure everything is working. The archives here have plenty of posts on this but I'm not too sure of the proper search words.

  5. #4
    69DVC's Avatar
    69DVC is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Oct 2006
    Location
    Dublin, Ireland
    Posts
    92

    Re: How can I get this beauty running sweet again??

    Will check those items, thanks very much guys

    It appears that there is no vacuum advance unit on my distributor.
    Also I will investigate reconnecting the mech fuel pump.

    Thanks again.

    Jon

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting