Any advice on this?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 9 of 9
500, 472, 425, 368 Discussion, Any advice on this? in Cadillac Engine Technical Discussion; I just purchased my first caddy....a 1979 sedan deville, with a 425 4 barrel carb. 90k miles on it,,,pretty clean ...
  1. #1
    79caddy1's Avatar
    79caddy1 is offline Cadillac Owners Member
    Join Date
    Jul 2006
    Location
    PGH, Pa.
    Posts
    67

    Any advice on this?

    I just purchased my first caddy....a 1979 sedan deville, with a 425 4 barrel carb.
    90k miles on it,,,pretty clean car...

    It is running rough, and missing. It seems to be lacking power.

    If I have the car in park or neutral, it will rev up just fine, nice and smooth.

    When I put it in gear, it seems to be running rough when I hit the gas, like a miss and sputters up the road.. And lack of power.

    I can't make sense of it. I checked, and someone before me has put in new plugs, they look clean,. and also the wires seem fine. Gas filter is new, cap and rotor are new,..

    I just repleced the ignition module, from messing around, and pulling wires while it was running, the module blew out. I repleced it, and of course, it fired right back up, and still the sam,e problem though.

    Has anyone run into this, or have advise. Thanks so much in advance, looking forward to driving this caddy, and having a new home here on this forum,,,,Tony

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    carnut is offline Cadillac Owners Master
    Automobile(s): 1988 Allante' (sold), 1984 Eldorado, 84 Sedan DeVille
    Join Date
    Feb 2003
    Location
    california
    Age
    66
    Posts
    5,699

    Re: Any advice on this?

    Run a compression test to rule out internal engine problems. Ideally this car should be hooked up to a scope to see the firing line to rule out secondary ignition problems. If both tests are within spec then I would look for a vacuuum leak.

  4. #3
    79caddy1's Avatar
    79caddy1 is offline Cadillac Owners Member
    Join Date
    Jul 2006
    Location
    PGH, Pa.
    Posts
    67

    Re: Any advice on this?

    Thanks.....I should have checked for a leak, didn't think of that one.

    I was trying to keep from taking it to the machine. Is it possible to get a new bad plug or wire?

  5. #4
    Junkman's Avatar
    Junkman is offline Cadillac Owners Fanatic
    Automobile(s): '78 Superior Cadillac Amublance, '69 Miller Meteor Ambulance
    Join Date
    Dec 2004
    Location
    Northeast CT
    Posts
    243

    Re: Any advice on this?

    Quote Originally Posted by 79caddy1
    .......... Is it possible to get a new bad plug or wire?
    Defective new parts are always a possibility. Check the vacuum release on the emergency brake. Seems that it is a common source of problems. Considering the age of the car, there is a possibility that any of the vacuum hoses could be cracked and in need of replacement. Also check the brake booster hose where it enters at the back of the carburetor. This is another common problem area. Junk....

  6. #5
    79caddy1's Avatar
    79caddy1 is offline Cadillac Owners Member
    Join Date
    Jul 2006
    Location
    PGH, Pa.
    Posts
    67

    Re: Any advice on this?

    Thanks....I checked for leaks this morning, and found nothing. Actually, it looks like somone replaced all the lines. The motor is really clean, but still missing and rough, when trying to drive it. I cannot believe how smooth it is and revs up, when out of gear.

  7. #6
    Sasquatch's Avatar
    Sasquatch is offline Cadillac Owners Fanatic
    Join Date
    Mar 2004
    Location
    Bluff Creek
    Posts
    320

    Re: Any advice on this?

    Vac advance in the distributor?

  8. #7
    79caddy1's Avatar
    79caddy1 is offline Cadillac Owners Member
    Join Date
    Jul 2006
    Location
    PGH, Pa.
    Posts
    67

    Re: Any advice on this?

    i pulled the vac advance, and it idled down, I am wondering if the advance is working, now that you brought it up.....

  9. #8
    79caddy1's Avatar
    79caddy1 is offline Cadillac Owners Member
    Join Date
    Jul 2006
    Location
    PGH, Pa.
    Posts
    67

    Re: Any advice on this?

    It is fixed....The wires I bought were junk!

    I pulled number 8 plug, and it was black....I changed that plug, and put better wires on, and it runs perfect.....WOW...My first caddy....I am impressed....whatta smoooooooooth ride!

  10. #9
    davesdeville's Avatar
    davesdeville is offline Banned
    Automobile(s): 1995 ETC, 75 Deville, Cad500 powered 73 Apollo, 94 Mark VIII
    Join Date
    Aug 2003
    Location
    Albuquerque, NM
    Age
    26
    Posts
    7,971

    Re: Any advice on this?

    Glad you got it figured out, enjoy the ride.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting