New Member
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
500, 472, 425, 368 Discussion, New Member in Cadillac Engine Technical Discussion; Hi, Just found the website and am looking forward to all the experience that is out there. I have a ...
  1. #1
    55 Chevy is offline Cadillac Owners Member
    Join Date
    Dec 2003
    Location
    Placerville, CA
    Posts
    7

    New Member

    Hi, Just found the website and am looking forward to all the experience that is out there. I have a 1974 500 Cad in my 55 Chevy Pick up. I have been trying to get what seem to be an endless list of troubles figured out. When I pulled the engine out of a 74 as a 472. We put in a 500 crank totally rebuilt it. The first problem we found was it had the small chamber heads and we rebuilt it as having the large chamber. Way to much compression. Put on new heads with bigger valves and new rockers. Also found that one lobe of the cam had gone flat, replaced with a new one. I now have a knock that I can't seem to find, haven't had time to really dig into it, but I hope it isn't lifter or cam again. Seems to show up or get worse when under power going up a hill or giving it gas, but doesn't sound like a timing or gas knock (I could be wrong). The timing is set at 10 degrees, but just doesn't seem to be right. It shows right when using a timing light, but there are indications that it is off (rough idle, blow back when I shut it off sometimes, etc). Is there a expert that lives somewhere in Northern California. I sure would like to get this truck and engine running right.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    elwesso's Avatar
    elwesso is offline Cadillac Owners Master
    Automobile(s): 2005 CTS-V, 1994 Infiniti Q45
    Join Date
    Jan 2003
    Location
    Indiana
    Posts
    7,668

    Re: New Member

    Welcome aboard.... And thanks for signing up

    We'll keep this an intro thread, and Ill post this again in the pushrod section! We have another guy on here (lux hauler) who is doing basically the same thing you are..... I bet he wil have some good insight to your inquiries....

  4. #3
    DaveSmed's Avatar
    DaveSmed is offline Cadillac Owners Connoisseur
    Automobile(s): 1968 Cadillac Sedan deVille, 1994 Chevrolet G20
    Join Date
    Aug 2003
    Location
    Bucks County, PA
    Age
    27
    Posts
    2,795

    Re: New Member

    Hrm. If it talks like a duck...... I think the best thing to do would be pull the intake and check that lifter location. You might have an oil delivery problem to that lifter bore.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting