Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 9 of 9

Thread: Weird sputtering issue

  1. #1
    Join Date
    Jun 2013
    Age
    30
    Posts
    4

    Weird sputtering issue

    Hey guys, I have recently come into possession of a '70 DeVille 472.

    We rebuilt the carb and virtually nothing else done, then I made the journey from ATL to Ft. Bragg NC (400 miles).

    Along the way I ran into a largely inconveniencing issue - At first it went a good 40 miles with no issues at HWY speed (70mph),
    however after about 40 miles it got to where every 5 miles or so at HWY speed it would start to sputter and jerk (similar to when
    spark plug wires are going bad) however, if I tried to continue it at a furious pace it would continue to sputter and slowly beat me down
    to a lower speed.

    Say I started at 70, ran about 2 miles or so, it would start sputtering (on hills especially) requiring me to give it less and less gas, working me
    down from 70 to 60, then to 50, and after about a total of 5 miles or so it would force me to go 40 and under, making me either pull off onto
    the shoulder for about 30 seconds to idle, or off an exit long enough to turn around and get right back on the HWY to rinse and repeat.

    Around town she runs great, I would assume its all of the stop and go. My assumption originally was that the car was somehow flooding itself
    like maybe the float was getting stuck or something but jiggling the pedal and the fact that it is 100% reproducible the same way every time
    makes me think it has more to do with the fuel pump itself.

    I'm not terribly mechanically inclined, and I dont have access to a huge assortment of tools, so my questions are: does it seem from the sounds of it
    to be the fuel pump? and if so, how difficult is it to replace one?

    Also, what would any of you previous 472 owners recommend I start with as far as general replacements for parts known to be outdated or obsolete?

    Any and all help is appreciated guys!


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    cadillac_al is offline Cadillac Owners Connoisseur
    Automobile(s): 70 Deville 77 Fleet 78 Seville 92 Deville 03 Deville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    55
    Posts
    3,310

    Re: Weird sputtering issue

    It sounds like it is starving for gas to me. Either a plugged fuel filter or bad fuel pump.

  4. #3
    The Ape Man's Avatar
    The Ape Man is offline Cadillac Owners Connoisseur
    Automobile(s): '80 Fleetwood Coupe, 1994 and 1995 Mercedes 140 Coupe
    Join Date
    Feb 2005
    Location
    Southern NJ
    Age
    54
    Posts
    2,096

    Re: Weird sputtering issue

    Been there. My case it was the fuel pump pumping all fuel back to the tank via the bypass. A quick way to check is pinch the return hose back to the tank and go for a test drive. In my case it was a less than 2 year old Airtex pump. Replaced with another Airtex pump. Stayed working almost forever.

  5. #4
    deVille33 is offline Cadillac Owners Connoisseur
    Automobile(s): 1977 Coupe (blue), 1977 Coupe (yellow), 1977 Coupe (green)
    Join Date
    Mar 2006
    Location
    Western Massachusetts
    Posts
    1,493

    Re: Weird sputtering issue

    I, personally don't like Airtex products and it doesn't matter which one. Fuel pump, water pump, whatever, usually lasts one year, just past the warrantee, then failure. I use AC, or Carter units for replacement parts. I hate doing a job more than once over a short period of time.

  6. #5
    Join Date
    Jun 2013
    Age
    30
    Posts
    4

    Re: Weird sputtering issue

    Just thought I would post an update for you guys:

    It was indeed the fuel pump. The car actually broke down on me on the expressway, luckily I was only 2 miles from my barracks so I got it towed back free thanks to AAA.
    I picked up a new fuel pump for 33$ at O'Riley, spent about 60$ on tools and went to town in my parking lot. It took me about 3 hours (I have no mechanical knowledge whatsoever), but I was able to install the new fuel pump and after a minute of pumping the gas while turning the key she fired right up.

    The fuel filter in the bottom of the old pump was so filled with dirt and crap that it was falling out in marble sized chunks as I tapped it on the ground. I took it out last weekend about 50m away to another city with absolutely no problems whatsoever, however on the way back I had it sputter on me one time, so I know that I need to probably change the fuel filter again, or get into the filter in the carb itself and see how bad caked up that one is.

    My goal now is to get one of those fancy HEI distributors in the car, but I have absolutely no clue where to even start so this will be interesting. Thanks for all the help guys!

  7. #6
    The Ape Man's Avatar
    The Ape Man is offline Cadillac Owners Connoisseur
    Automobile(s): '80 Fleetwood Coupe, 1994 and 1995 Mercedes 140 Coupe
    Join Date
    Feb 2005
    Location
    Southern NJ
    Age
    54
    Posts
    2,096

    Re: Weird sputtering issue

    If you get any new junk sucked into the pump it may do the same as the last pump.

    Might be time just to bite the bullet and replace the gas tank and gas tank straps for cheap insurance.

  8. #7
    Join Date
    Jun 2013
    Age
    30
    Posts
    4

    Re: Weird sputtering issue

    Oh man don't tell me that!

    What kind of money would I be looking at for that?

  9. #8
    drmenard is online now Cadillac Owners Connoisseur
    Automobile(s): 95 FWB 81SDV 96 FWB 94 Fleetwood
    Join Date
    May 2003
    Location
    Massachusetts
    Posts
    1,196

    Re: Weird sputtering issue

    I think ape man is right. The tank has got crap in it. If its not leaking it could be cleaned out.. But still has to come out.

  10. #9
    deVille33 is offline Cadillac Owners Connoisseur
    Automobile(s): 1977 Coupe (blue), 1977 Coupe (yellow), 1977 Coupe (green)
    Join Date
    Mar 2006
    Location
    Western Massachusetts
    Posts
    1,493

    Re: Weird sputtering issue

    Replacement tanks go for around $125.00, but dr is right. With some effort and patience, you can clean out the old one, provided there are no holes that get exposed in the process. Sounds like you need a new sock on the pick-up tube also.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum