81 Fleetwood wont stay running after start
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7
500, 472, 425, 368 Discussion, 81 Fleetwood wont stay running after start in Cadillac Engine Technical Discussion; HI, I have a 1981 Fleetwood brougham with 368 v864. The car was running fine. Then a few days ago ...
  1. #1
    98CDEVILLE is offline Cadillac Owners Member
    Automobile(s): 1981 FLEETWOOD BROUGHAM, 1990 CADILLAC BROUGHAM
    Join Date
    Mar 2009
    Location
    TX
    Age
    37
    Posts
    5

    81 Fleetwood wont stay running after start

    HI, I have a 1981 Fleetwood brougham with 368 v864. The car was running fine. Then a few days ago it would shut down without notice as if you turned off the key. You could restart and it would be fine. The problem started happen more often each day. Engine hot or cold does not matter.Now today it will start as normal then within 10 seconds turn off as if you turned off the key. Even if I rev the motor. I have replaced the ignition module, fuel pump, sending unit, full tune up with factory parts, water pump, coolant sensor, o2 sensor, alt and battery.. There are no codes and I do have a fsm.. Cant seem to figure this out. Thanks for any help Jeff

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    lacville'78 is offline Cadillac Owners Member
    Join Date
    Jul 2012
    Posts
    1
    I had the same prob with my 78 eldo I thought it was the alt so I replaced it but kept happening. I opened the carb and cleaned it all out and sprayed inside the fuel lines with the cleaner and it took care of the prob. If yours is fuel injected you can get it cleaned out at like a Valvoline or quick lube place for like $60. Worked for me. Best of luck

  4. #3
    creeker is offline Cadillac Owners Connoisseur
    Automobile(s): 1992 eldorado. 2007 dodge magnum hemi r/t
    Join Date
    Nov 2005
    Location
    roberts creek b.c. canada
    Posts
    3,013

    Re: 81 Fleetwood wont stay running after start

    Fuel filter?, my 80 cdv had the fuel filter in the rochester carb. body.

  5. #4
    98CDEVILLE is offline Cadillac Owners Member
    Automobile(s): 1981 FLEETWOOD BROUGHAM, 1990 CADILLAC BROUGHAM
    Join Date
    Mar 2009
    Location
    TX
    Age
    37
    Posts
    5

    Re: 81 Fleetwood wont stay running after start

    Thanks for the response.. It turned out to be the fuel pump cutting out and not building pressure..Back to the auto store for replacement..

  6. #5
    The Ape Man's Avatar
    The Ape Man is offline Cadillac Owners Connoisseur
    Automobile(s): '80 Fleetwood Coupe, 1994 and 1995 Mercedes 140 Coupe
    Join Date
    Feb 2005
    Location
    Southern NJ
    Age
    52
    Posts
    2,096

    Re: 81 Fleetwood wont stay running after start

    Maybe check if the pump is still getting power once the car is started.

  7. #6
    drmenard is offline Cadillac Owners Enthusiast
    Automobile(s): 95 fleetwood 81 deville
    Join Date
    May 2003
    Location
    Massachusetts
    Posts
    974

    Re: 81 Fleetwood wont stay running after start

    That's right Jay it could be the fuel pump relay... I would hate to change the pump if it was the relay...

  8. #7
    98CDEVILLE is offline Cadillac Owners Member
    Automobile(s): 1981 FLEETWOOD BROUGHAM, 1990 CADILLAC BROUGHAM
    Join Date
    Mar 2009
    Location
    TX
    Age
    37
    Posts
    5

    Re: 81 Fleetwood wont stay running after start

    Thanks again for all the help. checked relay and switched it with a known good one off my 83 Fleetwood and it did the same thing. I use my meter and the computer is telling the relay to stay closed until car dies which is correct per fsm. The reason I think its the pump is that if I jumper the relay for the pump to run it sounds really bad as if its struggling to run and theres no pressure building up. If I remove the jumper and connect it back quickly a few times the pump makes a different sound and the car runs perfect. The pump I bought when I got my new fuel tank was cheap. This time I'll go for the high dollar one.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting