oil pump question
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
500, 472, 425, 368 Discussion, oil pump question in Cadillac Engine Technical Discussion; I have a 472 Cadillac motor in a 4 seat dune buggy. My question is I don't think its pumping ...
  1. #1
    badams270 is offline Cadillac Owners Member
    Automobile(s): 472 cadillac
    Join Date
    Feb 2012
    Age
    37
    Posts
    4

    oil pump question

    I have a 472 Cadillac motor in a 4 seat dune buggy. My question is I don't think its pumping oil. I pulled the filter off and turned the pump by hand and oil came out. I put a new filter on and turned the pump with a pump primer. Its easy at first then becomes very hard like pressure building but no where to go. Could there be a blockage somewhere?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    drmenard is offline Cadillac Owners Enthusiast
    Automobile(s): 95 fleetwood 81 deville
    Join Date
    May 2003
    Location
    Massachusetts
    Posts
    983

    Re: oil pump question

    Is this a new pump? I have heard that some new pumps that the pressure relief get stuck open and lose pressure.. What guys do with a new pump , because of this is, remove the set screw and take out the spring and piston.. Then they polish the piston hone the bore and make sure there are no burrs and slids freely... Did you have the motor apart?

  4. #3
    grassisgreener is offline Cadillac Owners Member
    Automobile(s): 1968 Sedan DeVille - Bone Stock - Kasmir Ivory
    Join Date
    Dec 2011
    Location
    Rhode Island
    Age
    35
    Posts
    31

    Re: oil pump question

    All I can add is don't buy the pump Auto Zone has. Better to stick with the cast iron pump and buy a rebuild kit.

    Post a picture of the 472 in a buggy please.

  5. #4
    badams270 is offline Cadillac Owners Member
    Automobile(s): 472 cadillac
    Join Date
    Feb 2012
    Age
    37
    Posts
    4

    Re: oil pump question

    So, if I'm looking at the bottom of the pump. There is a hole thats open, and one with a little flap. What is the port with the flap? I have a rebuild kit, plan on installing it soon.

  6. #5
    badams270 is offline Cadillac Owners Member
    Automobile(s): 472 cadillac
    Join Date
    Feb 2012
    Age
    37
    Posts
    4

    Re: oil pump question

    Well, still no oil getting to the valve train? Pulled the front pressure switch, and its pumping that far. Pulled the back pressure switch and I get oil back there. Anyone know why its not pumping into the heads on either side?

  7. #6
    deVille33 is offline Cadillac Owners Connoisseur
    Automobile(s): 1977 Coupe (blue), 1977 Coupe (yellow), 1977 Coupe (green)
    Join Date
    Mar 2006
    Location
    Western Massachusetts
    Posts
    1,380

    Re: oil pump question

    Have you done work on the heads? Did you remove the rockershafts? You may have the shafts mounted so they block at oil passage. There is a special bolt (hollow) that goes into the oil passage port.

  8. #7
    badams270 is offline Cadillac Owners Member
    Automobile(s): 472 cadillac
    Join Date
    Feb 2012
    Age
    37
    Posts
    4

    Re: oil pump question

    I haven't done any work to the heads. Both sides no oil. I have a manual coming form ebay, guess Ill have to wait. I got a oil pressure testing kit last night and have 35 lbs at idle. Where is this hollow bolt you speak of? The rockers and valves get lubricated through the push rods, right? Thanks for your help!!

  9. #8
    drmenard is offline Cadillac Owners Enthusiast
    Automobile(s): 95 fleetwood 81 deville
    Join Date
    May 2003
    Location
    Massachusetts
    Posts
    983

    Re: oil pump question

    The rockers get there oil through the pushrods from the lifters... There are freeze plugs under the intake that plug a oil passage .. If one pops out you loose a lot of pressure.. If the lifters are clicking they could haved lost pressure...But if you got 35psi I would pull out some pushrods and see if they are blocked..

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting