1970 500 not running right!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 9 of 9
500, 472, 425, 368 Discussion, 1970 500 not running right! in Cadillac Engine Technical Discussion; ...
  1. #1
    02STSVT's Avatar
    02STSVT is offline Cadillac Owners Member
    Automobile(s): 2002 STS, 1988 Seville R.I.P., 1970 Eldorado (New Toy)
    Join Date
    Oct 2007
    Location
    Vermont
    Posts
    7

    1970 500 not running right!

    Ok guys hereís how it goes. A couple of weekends ago I took my 1970 Eldorado with 57K miles out for a drive around town. She ran great! I just took a weekend ride; I didnít beat on her, didnít fool around or anything, just went for a ride. I came home, parked the car in the driveway and went inside. About 3 hours later I decided it was time to put her away in the garage. I started the engine and it stalled right away. So I tried again, managed to get it running, but it would not idle. I figured I did something and hoped the issue would resolve itself. The next day the car ran like crap. No power to speak of, difficult to start and I had to drive like an old lady with on foot on the gas to keep it from stalling. I decided to replace the distributor cap, rotor, checked plugs and wires and finally broke down and had a spare carb rebuilt and put on the car. The rebuilt carburetor seemed to help a little bit, but did not solve the problem. So I donít think its fuel related. Next I took the car to a local shop where they determined that the timing was way off, it is very late. Currently they are trying to get the distributor to turn so they can set the timing but are having trouble getting it to move. But no guarantee thatís gonna fix the problem. Any ideas guys? I really donít think itís the timing chain since this problem just happened all at once. Iím thinking that there is something going on inside the distributor. Any help Iíd really appreciate! Thanks, Seth

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    drmenard is offline Cadillac Owners Enthusiast
    Automobile(s): 95 fleetwood 81 deville
    Join Date
    May 2003
    Location
    Massachusetts
    Posts
    956

    Re: 1970 500 not running right!

    What I think happened is the plastic coating on the timing gear broke and came off... happenes alot when the motor is shut off...Check to see if there is too much play in the chain and gears...jumping a tooth will bend valves... Do not use a cheap $35 chain and gears... the good ones are $85 to $100 plus and are sprokets and roller chain...

  4. #3
    02STSVT's Avatar
    02STSVT is offline Cadillac Owners Member
    Automobile(s): 2002 STS, 1988 Seville R.I.P., 1970 Eldorado (New Toy)
    Join Date
    Oct 2007
    Location
    Vermont
    Posts
    7

    Re: 1970 500 not running right!

    Thanks for the quick reply! So this plastic coating on the timing gear is behind the timing cover right? Or is that something in the distributor. It did seem as if the rotor had a little too much play in it. I really do want to avoid getting into that timing cover. Thanks again!

  5. #4
    steelybill is offline Cadillac Owners Enthusiast
    Automobile(s): '85 FWD fleetwood, '93 fleetwood Bro
    Join Date
    Mar 2009
    Location
    mich
    Age
    82
    Posts
    721

    Re: 1970 500 not running right!

    Yes, it's behind the timing cover. If it failed, it's likely because of age. Plastic does get brittle with age sometimes. It's not likely your distributor. If the timing is late now, as opposed to where it was earlier, the timing sprocket is highly suspect, and the chain may have moved a whole tooth on the sprocket. That's also what bends valves, when the cam is retarded, like drmenard said. The auto shop you went to should have known that when the timing became late, the timing set was affected by the sprocket failure.

  6. #5
    BRUCE ROE is offline Cadillac Owners Fanatic
    Automobile(s): Eldorado
    Join Date
    Jun 2009
    Posts
    207

    Re: 1970 500 not running right!

    You can check the timing chain. Rock the crank by hand, see how many degrees it goes before the distributor rotor starts to follow it. 6 degrees means its gone. Even if it hasn't failed outright yet, it probably will. Change it now, or the car will tell you when to change it (at the side of the road). Bruce Roe CLC # 14630

  7. #6
    cadillac_al is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    52
    Posts
    2,679

    Re: 1970 500 not running right!

    If the distributor is frozen to the block, I doubt if the timing moved. I would check the vacuum. It's usually always a problem with points and condenser. Back in the day I couldn't get a set of points to last over a year.

  8. #7
    deVille33 is offline Cadillac Owners Connoisseur
    Automobile(s): 1977 Coupe (blue), 1977 Coupe (yellow), 1977 Coupe (green)
    Join Date
    Mar 2006
    Location
    Western Massachusetts
    Posts
    1,335

    Re: 1970 500 not running right!

    How have you made out with this problem?

  9. #8
    02STSVT's Avatar
    02STSVT is offline Cadillac Owners Member
    Automobile(s): 2002 STS, 1988 Seville R.I.P., 1970 Eldorado (New Toy)
    Join Date
    Oct 2007
    Location
    Vermont
    Posts
    7

    Re: 1970 500 not running right!

    Hey guys. Well its all fixed. Seemed it did jump timing after all! Thankfully it does not appear any damage was done. Now on with the small stuff

  10. #9
    steelybill is offline Cadillac Owners Enthusiast
    Automobile(s): '85 FWD fleetwood, '93 fleetwood Bro
    Join Date
    Mar 2009
    Location
    mich
    Age
    82
    Posts
    721

    Re: 1970 500 not running right!

    Great to hear you have it fixed OK

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting