Samll leak after install of 160 Thermo?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 15 of 15
2009-2014 Cadillac CTS-V Performance Mods Discussion, Samll leak after install of 160 Thermo? in Cadillac CTS-V Series Forum - 2009-2014; Hey guys I might need help. I changed the Thermostat and I have a small leak. I have tighten to ...
  1. #1
    LSUFoolsball is offline Cadillac Owners Member
    Automobile(s): 2009 CTS-V Sedan All options
    Join Date
    Feb 2013
    Age
    32
    Posts
    40

    Samll leak after install of 160 Thermo?

    Hey guys I might need help. I changed the Thermostat and I have a small leak. I have tighten to spec and I still have a small leak. I was seeing if not lining the rubber gasket right would be the issue. Just want to see what you say before I break it down again.

    Thanks

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    LSUFoolsball is offline Cadillac Owners Member
    Automobile(s): 2009 CTS-V Sedan All options
    Join Date
    Feb 2013
    Age
    32
    Posts
    40

    Re: Samll leak after install of 160 Thermo?

    Anybody?

  4. #3
    cruiser68 is online now Cadillac Owners Enthusiast
    Automobile(s): 2011 CTS-V A6 Sedan Modded :)
    Join Date
    May 2011
    Location
    Chicagoland
    Posts
    615

    Re: Samll leak after install of 160 Thermo?

    I would check the rubber gasket and use scotchbrite to clean up the metal mating surface before re-installing. Also you could compare the old/new gaskets to see if there is any differences.

  5. #4
    LSUFoolsball is offline Cadillac Owners Member
    Automobile(s): 2009 CTS-V Sedan All options
    Join Date
    Feb 2013
    Age
    32
    Posts
    40

    Re: Samll leak after install of 160 Thermo?

    Well there is not gasket on the Housing now there is one on the Thermostat. I think I read somewhere it has to be lined up. If not it might leak some.

  6. #5
    Snotty Boom Body is offline Cadillac Owners Fanatic
    Automobile(s): 13 V Coupe Thunder Gray
    Join Date
    Mar 2013
    Posts
    153
    Shouldn't there be a gasket or rubber O-ring to seal the housing to the motor
    .

  7. #6
    LSUFoolsball is offline Cadillac Owners Member
    Automobile(s): 2009 CTS-V Sedan All options
    Join Date
    Feb 2013
    Age
    32
    Posts
    40

    Re: Samll leak after install of 160 Thermo?

    I dunno I did not notice one. I thought about RTV to seal it but that stuff is messy.

  8. #7
    ClarkkentCTSV is offline Cadillac Owners Fanatic
    Automobile(s): 2009 Thunder gray CTS V
    Join Date
    Jun 2012
    Location
    South Florida
    Age
    32
    Posts
    215

    Re: Samll leak after install of 160 Thermo?

    I remember when installing my 160 thermostat that it has to go in a certain way or else it would leak. It will go into the hole, but it wound not seat properly and you will need to find the sweet spot for it to fit correctly and not leak. Remove the housing and then rotate the thermostat until you feel it seat correctly.

  9. #8
    miamictsv is offline Cadillac Owners Fanatic
    Automobile(s): 2009 CTS-V
    Join Date
    Jul 2010
    Posts
    162

    Re: Samll leak after install of 160 Thermo?

    My Mechanic just told me that i also have small leak from my 160 thermostat. I will service it as soon as i get my bigger issue resolve. I need to replace my evaporator due to leaking. $700 labor ... ouch

  10. #9
    LSUFoolsball is offline Cadillac Owners Member
    Automobile(s): 2009 CTS-V Sedan All options
    Join Date
    Feb 2013
    Age
    32
    Posts
    40

    Re: Samll leak after install of 160 Thermo?

    I think it has a notch at the top. I will take it off and try again. Thanks.

  11. #10
    CavemanB52's Avatar
    CavemanB52 is offline Cadillac Owners Enthusiast
    Automobile(s): 2012 CTSV coupe
    Join Date
    Aug 2012
    Posts
    962
    Mine is fine.

  12. #11
    THE////V is offline Cadillac Owners Member
    Automobile(s): 2012 ctsv sedan
    Join Date
    Mar 2013
    Posts
    21
    I'm interested to know do any of these engines run at 160 deg. When driven hard or even on a hot day with the air on ?.. I was thinking about it I have din it and every car I installed on on unless it was 20 deg. Out still ran over 200 . How about the V horsepower = heat.

  13. #12
    miamictsv is offline Cadillac Owners Fanatic
    Automobile(s): 2009 CTS-V
    Join Date
    Jul 2010
    Posts
    162

    Re: Samll leak after install of 160 Thermo?

    Mine runs at around 200 deg when fully warmed in South Florida Heat. Before it will run at around 210-215 deg. I am boosting 15PSI as well.

    Quote Originally Posted by THE////V View Post
    I'm interested to know do any of these engines run at 160 deg. When driven hard or even on a hot day with the air on ?.. I was thinking about it I have din it and every car I installed on on unless it was 20 deg. Out still ran over 200 . How about the V horsepower = heat.

  14. #13
    CavemanB52's Avatar
    CavemanB52 is offline Cadillac Owners Enthusiast
    Automobile(s): 2012 CTSV coupe
    Join Date
    Aug 2012
    Posts
    962
    I'm only boosting to 13. Used to run about 195ºF stock. Now I run the Track Attack Hx and a 160 thermostat today I noticed running at 175ºF after several pulls and running for an hour.

  15. #14
    rbzstsv is offline Cadillac Owners Fanatic
    Automobile(s): stsv
    Join Date
    Mar 2013
    Posts
    422
    06 sts v here. Car runs 178° tstat. Before hx by TimC it was running about 198° to 210° with iat2 from 170°-190° depending on driving style. After hx/jabsco pump install the car never runs hotter than 190° - 195° with iat2 at 115°-160° (85° to 90° outside), even after a long stretch of spirited driving.

  16. #15
    Gary Wells is offline Cadillac Owners Connoisseur
    Automobile(s): '09 CTS-V, 3K miles & '87 Turbo Buick, 29K miles
    Join Date
    May 2009
    Location
    Long Beach, Kali
    Age
    70
    Posts
    3,266

    Re: Samll leak after install of 160 Thermo?

    Check the rubber boot at the top of the metal pipe.
    Mine went bad at & developed a hole / separation at the inside of the 90˚ bend on the rubber boot.
    $30 for that stupid little rubber boot.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting