Windshield Washer Pump?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 11 of 11
Like Tree2Likes
  • 2 Post By FLTRI
2009-2014 Cadillac CTS-V General Discussion Discussion, Windshield Washer Pump? in Cadillac CTS-V Series Forum - 2009-2014; Just got my 2011 V-Coupe a few weeks ago, and the washer fluid seems to spray very weakly --- only ...
  1. #1
    fin
    fin is offline Cadillac Owners Member
    Automobile(s): CTS V Coupe - 2011
    Join Date
    Feb 2014
    Posts
    36

    Windshield Washer Pump?

    Just got my 2011 V-Coupe a few weeks ago, and the washer fluid seems to spray very weakly --- only hitting the very bottom of the windshield. I had the local Caddy dealer look at it, and they said that this is normal. It just doesnt seem normal to me, since it barely reaches the windshield. --------- Does anyone know if this is actually normal, or had this issue?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    baabootoo's Avatar
    baabootoo is offline Cadillac Owners Connoisseur
    Automobile(s): Blue/Titanium 2009 V Auto
    Join Date
    May 2010
    Location
    Racine, WI
    Posts
    3,185

    Re: Windshield Washer Pump?

    Nah, that's a load. Unless you're going over 100, it should hit the middle. Could they be a little frozen inside?

  4. #3
    fin
    fin is offline Cadillac Owners Member
    Automobile(s): CTS V Coupe - 2011
    Join Date
    Feb 2014
    Posts
    36

    Re: Windshield Washer Pump?

    I thought that may have been the case, but I did try it on the few days it got above freezing, and it still barely made it onto the bottom of the windshield. Its certainly not a major issue at this point, but its a bit annoying.

  5. #4
    Cadillac Cust Svc's Avatar
    Cadillac Cust Svc is offline Cadillac Customer Service
    Automobile(s): All Cadillac vehicles!
    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    10,920

    Re: Windshield Washer Pump?

    Quote Originally Posted by fin View Post
    Just got my 2011 V-Coupe a few weeks ago, and the washer fluid seems to spray very weakly --- only hitting the very bottom of the windshield. I had the local Caddy dealer look at it, and they said that this is normal. It just doesnt seem normal to me, since it barely reaches the windshield. --------- Does anyone know if this is actually normal, or had this issue?
    Hi fin,

    Firstly, congratulations on the new purchase! I hope you enjoy cruising in your V-Coupe throughout the summer.
    I apologize that you do not feel the washer fluid spray is working properly. If you would like me to look into the problem, please PM me with your VIN, mileage, dealership, and contact information. I hope to hear from you soon.

    Austin J.
    Cadillac Customer Care

  6. #5
    Trapspeed's Avatar
    Trapspeed is offline Cadillac Owners Connoisseur
    Automobile(s): 2009 CTS-V
    Join Date
    May 2011
    Location
    Central Florida
    Posts
    2,377
    Not normal at all.

  7. #6
    Zhariak is offline Cadillac Owners Enthusiast
    Automobile(s): 2013 Escalade ESV Platinum, 2013 CTS-V Coupe 6MT
    Join Date
    Feb 2008
    Location
    Calgary, AB
    Age
    27
    Posts
    616

    Re: Windshield Washer Pump?

    As everyone else is saying, not normal at all.

    I've had 2 X 2nd gen V's... Both of the sprayers were effin AWESOME... So high powered, they could be used at high speeds and still function perfectly.

    They work so well, even when the windshield is dirty as shit, you don't even need to press it for a full second, and it'll clear everything up.

  8. #7
    RapidRob's Avatar
    RapidRob is offline Cadillac Owners Connoisseur
    Automobile(s): 2009 CTS-V Black/Black, manual
    Join Date
    Dec 2008
    Location
    Seattle area
    Posts
    1,206

    Re: Windshield Washer Pump?

    As mentioned - make sure the washer system isn't frozen. It may take it more than 1 warm day for everything to thaw out ...

  9. #8
    BlownCaddy806's Avatar
    BlownCaddy806 is offline Cadillac Owners Member
    Automobile(s): 2011cts v
    Join Date
    Nov 2013
    Location
    Great state of Texas
    Posts
    67

    Re: Windshield Washer Pump?

    If it ain't frozen make sure the hole on the sprayer isn't partially clogged. I had one stop working all together and I just used a thumb tack to clean it and works great again. Here it happens because of the constant blowing dirt.

  10. #9
    Zhariak is offline Cadillac Owners Enthusiast
    Automobile(s): 2013 Escalade ESV Platinum, 2013 CTS-V Coupe 6MT
    Join Date
    Feb 2008
    Location
    Calgary, AB
    Age
    27
    Posts
    616

    Re: Windshield Washer Pump?

    I'm wondering if someone put water in it, it froze, and something cracked?

    I've used mine in -20 Celsius before, no issues (keep in mind I was using normal anti-freeze).

  11. #10
    fin
    fin is offline Cadillac Owners Member
    Automobile(s): CTS V Coupe - 2011
    Join Date
    Feb 2014
    Posts
    36

    Re: Windshield Washer Pump?

    Thanks everyone, after finally giving it a more thorough look --- turns out it was something as simple as a hole in the fluid line. Not sure how that happened (looks like a mouse took a bite out of it), but anyway I did a temporary fix with good ole duct tape -- now it sprays to no end , i'll replace the line later. Thanks again.

  12. #11
    FLTRI's Avatar
    FLTRI is offline Cadillac Owners Enthusiast
    Automobile(s): 2011 V-Wagon & 2012 SRX Premium
    Join Date
    Jul 2011
    Location
    Las Vegas, NV
    Age
    50
    Posts
    810

    Re: Windshield Washer Pump?

    Quote Originally Posted by fin View Post
    Thanks everyone, after finally giving it a more thorough look --- turns out it was something as simple as a hole in the fluid line. Not sure how that happened (looks like a mouse took a bite out of it), but anyway I did a temporary fix with good ole duct tape -- now it sprays to no end , i'll replace the line later. Thanks again.
    What you really found out is you have a crappy dealer service department. If they can't fix a hole in a washer hose, are you really going to trust them with the big stuff???
    tinman and BlownCaddy806 like this.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting