Beltronics STI-R Radar Detector Not Detecting
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
2009-2014 Cadillac CTS-V General Discussion Discussion, Beltronics STI-R Radar Detector Not Detecting in Cadillac CTS-V Series Forum - 2009-2014; Hi all, I had a Beltronics STI-R detector installed in my car along with the laser interceptor laser jammers. The ...
  1. #1
    stuckbehindaprius is offline Cadillac Owners Member
    Automobile(s): 2011 6sp CTS-V Wagon
    Join Date
    Apr 2012
    Posts
    37

    Beltronics STI-R Radar Detector Not Detecting

    Hi all, I had a Beltronics STI-R detector installed in my car along with the laser interceptor laser jammers. The laser interceptor works great, the Beltronics does not. I have to be right in front of the cop for it to go off, then it's only about one little bar on the graph. I'm including a picture of where the sensor is on my dash; is this location preventing it from detecting radar or could it be a defective unit? The installer said there wasn't much they could do about it.

    http://i.imgur.com/837o3.jpg?1

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    JFJr's Avatar
    JFJr is offline Cadillac Owners Connoisseur
    Automobile(s): 2009 CTS-V (TR-6060, Black Raven/Ebony, Recaros, Ultraview)
    Join Date
    Jan 2009
    Location
    Jacksonville, FL
    Age
    71
    Posts
    1,424
    Could be that the metal wipers are reflecting/blocking radar waves. Try moving it higher and you'll find out.

    Jud
    Jud

  4. #3
    Crystal Red CTS-V is offline Cadillac Owners Fanatic
    Automobile(s): 2012 CTS-V CRM Coupe (Airaid Intake & Corsa), 2011 Z06/Z07
    Join Date
    Oct 2011
    Location
    Beech Mountain, NC
    Posts
    248

    Re: Beltronics STI-R Radar Detector Not Detecting

    +1. My Valentine's manual says not to mount the detector directly in front of the wiper blades and to get it up as high as possible.

  5. #4
    Wannago's Avatar
    Wannago is offline Cadillac Owners Fanatic
    Automobile(s): 2009 CTS-V, Black, Auto
    Join Date
    Jul 2010
    Location
    Calgary, Alberta
    Posts
    344

    Re: Beltronics STI-R Radar Detector Not Detecting

    Quote Originally Posted by stuckbehindaprius View Post
    Hi all, I had a Beltronics STI-R detector installed in my car along with the laser interceptor laser jammers. The laser interceptor works great, the Beltronics does not. I have to be right in front of the cop for it to go off, then it's only about one little bar on the graph. I'm including a picture of where the sensor is on my dash; is this location preventing it from detecting radar or could it be a defective unit? The installer said there wasn't much they could do about it.

    http://i.imgur.com/837o3.jpg?1
    I have the exact same setup. Just add a Valentine 1 (for the rear antenna and the arrows) and some rear LI heads and you have arguably the best setup rolling.

    Now, as to your specific problem...I hate to say this, but I think it's your INSTALLER that is your main problem.

    First and foremost, the "sensor" that you are talking about (and that is shown in the picture) is NOT your receiver....that's your GPS antenna.

    I have attached a link showing some intall pictures in my V. In mine, the installer put that GPS antenna under my dash right in front of my instrument cluster, and it works perfectly there (see the third picture in the link below). The location of your GPS antenna is NOT causing your problems, and no offense, but just sticking your GPS antenna to the dash like that isn't really an "install" in my books.

    In the second picture in my link, you can see where we mounted my antenna. It is just inboard of the driver's side headlight, mounted on the bumper. Obviously it is completely hidden behind the bumper cover, but ity works perfectly there as radar (microwaves) pass right through the bumper cover material as if it isn't even there (my car is Black Raven, the particles in the Black Diamond paint might interfere with reception). Of course, the antenna can't pick up LIDAR being behind the bumper, but I have the LIs for that and I have LIDAR disabled in my STiR + settings.

    The fact that you are getting very weak alerts indicates that the unit seems to be working. What I suspect is that wherever your "installer" mounted your receiver, it is almost completely blocked by something causing very weak reception.

    Where is your actual receiver mounted? Send some pics. I would suggest you will need to go back to your installer and have him do it properly. From waht I've seen so far, I might even ask for a refund or some money back and take it somewhere else. Send a picture of your LI heads as well....the installation of the LI heads is CRITICAL - location, square, level, etc. ....and if the same place installed those, I am willing to bet you will have some major problems with those as well.


    Here's the link to my install pics:


    http://www.radardetector.net/forums/...ts-v-pics.html

  6. #5
    stuckbehindaprius is offline Cadillac Owners Member
    Automobile(s): 2011 6sp CTS-V Wagon
    Join Date
    Apr 2012
    Posts
    37

    Re: Beltronics STI-R Radar Detector Not Detecting

    Wow, thanks a ton. I hadn't realized that at all. I'll take a look through and go on a hunt for my LI heads this evening and get back to you!

  7. #6
    Wannago's Avatar
    Wannago is offline Cadillac Owners Fanatic
    Automobile(s): 2009 CTS-V, Black, Auto
    Join Date
    Jul 2010
    Location
    Calgary, Alberta
    Posts
    344
    No problem. This stuff is "kinda" my thing.

    Your LI heads should be very easy to find, as they need to be fully exposed to work properly. Hopefully your imstaller didn't try to hide them behind the grill etc.

    I'm more interestes to learn where he mounted your STiR Plus antenna. I think he must have really put it in a bad location.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting