Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 7 of 7

Thread: 2009 CTS engine is sputtering

  1. #1
    Nivek's Avatar
    Nivek is offline Cadillac Owners Fanatic
    Automobile(s): 2009 CTS Black\Ebony PDQ\FE3
    Join Date
    May 2007
    Location
    Hot a$$ Texas
    Age
    42
    Posts
    164

    2009 CTS engine is sputtering

    I have done some searches, but have not hit an exact issue/fix for a gen 2 cts.

    My CTS has recently started sputtering on acceleration. Sometimes slight and sometimes enough the check engine flashes, but then goes off. It is usually at low RPMs and seems to be near shifts in the transmission. I have been through 3 tanks of gas, so I do not think it is bad gas. I had them check for codes at Autozone, but there were none and the check engine light just pops on and off sometimes. The air filter has about 15,000 miles on it and the throttle body was replaced in January under warranty. It does not appear we can replace a fuel filter on these, so should I be looking at plugs and coil as the next culprit? Thoughts or anyone have something similar with a gen 2 CTS?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Jschmank's Avatar
    Jschmank is offline Cadillac Owners Fanatic
    Automobile(s): 08 Silver CTS AWD
    Join Date
    Dec 2005
    Location
    Topeka, Kansas
    Posts
    246

    Re: 2009 CTS engine is sputtering

    A bad coil may cause similar effects, but usually is accompanied by a solid check engine light, which sometimes flashes under acceleration. Seems like a lot of folks have had to replace #3 coil

  4. #3
    Joe is offline Cadillac Owners Fanatic
    Automobile(s): 08 CTS blk/blk
    Join Date
    Jul 2010
    Location
    MA
    Age
    68
    Posts
    383

    Re: 2009 CTS engine is sputtering

    This is a bit complex but after numerous trips to the dealer I took on the problem myself. Your engine could be sputtering (skipping) because of one of more fouled plugs or one of more defective coil packs. To make a long story short I ended up buying three new coil packs and all new OEM plugs and installed the new coil packs in the most difficult cylinders. Problem Solved!! If you're sucking a little oil that could be contributing to the skipping. Examine and write down what you find after removing all the old parts. If you are lucky (50/50 shot) you may have solved the problem but you may have to invest in a catch can for a potential oil problem. Oh ya grease up all the coil pack fittings to reduce moisture interference. Best of luck

  5. #4
    Nivek's Avatar
    Nivek is offline Cadillac Owners Fanatic
    Automobile(s): 2009 CTS Black\Ebony PDQ\FE3
    Join Date
    May 2007
    Location
    Hot a$$ Texas
    Age
    42
    Posts
    164

    Re: 2009 CTS engine is sputtering

    Update - Finally the check engine light came on and stayed. P0303 was the code, a miss-fire in cylinder 3. Since I am at 70k miles, I changed all the plugs out and cleared the CEL. It is running better and it does not seem to be sputtering now. Hopefully this it, but it seems many other people had to change coils as well.

    Plugs are pretty easy DIY and the coils are even easier. Before I did it myself, the dealer quoted me $500 to replace coil and plug. Just 1 of them, lol. You can do a plug and coil yourself in 30 minutes and under $100

  6. #5
    Tbbt is online now Cadillac Owners Connoisseur
    Automobile(s): 2010 CTS4 Premium Wagon-Diamond White-Cashmere Interior
    Join Date
    Aug 2012
    Location
    Castle Pines, CO
    Age
    73
    Posts
    2,402

    Re: 2009 CTS engine is sputtering

    Nivek,

    Great job! Keep us informed!

    Marv

  7. #6
    pgdrews is offline Cadillac Owners Member
    Automobile(s): 2014 CTS Luxury
    Join Date
    Feb 2012
    Location
    Atlanta, GA
    Age
    46
    Posts
    10
    Quote Originally Posted by Nivek
    Update - Finally the check engine light came on and stayed. P0303 was the code, a miss-fire in cylinder 3. Since I am at 70k miles, I changed all the plugs out and cleared the CEL. It is running better and it does not seem to be sputtering now. Hopefully this it, but it seems many other people had to change coils as well.

    Plugs are pretty easy DIY and the coils are even easier. Before I did it myself, the dealer quoted me $500 to replace coil and plug. Just 1 of them, lol. You can do a plug and coil yourself in 30 minutes and under $100
    I had sputtering recently on my 09 CTS DI as well. Replaced the plugs myself for under $40 and runs super now. 67k miles.

  8. #7
    leigh1322 is offline Cadillac Owners Member
    Automobile(s): 08 CTS 3.6 D.I. FE-3 6M Red
    Join Date
    Mar 2011
    Age
    61
    Posts
    74

    Re: 2009 CTS engine is sputtering

    Had similar problem on my 08. Three coils later and new plugs and all is well. One more easy thing to check: I believe my initial problem was caused by lean running due to a vacuum leak when the PCV hose repeatedly became disconnected at the valve cover fitting at the rear of the drivers valve cover. Mine must have gotten routed incorrectly at some point, and would go into place, but would come loose with engine movement a few days later. It needs to be routed correctly to stay seated. Easy thing to check, but ultimately caused me a lot of grief and many misfiring codes.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum