Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 4 of 4

Thread: UDP install issue

  1. #1
    darien99's Avatar
    darien99 is offline Cadillac Owners Fanatic
    Automobile(s): none
    Join Date
    Dec 2005
    Location
    Hazel Park, MI
    Age
    33
    Posts
    194

    UDP install issue

    So after fighting with my UDP install for a few hours, everything is put back together. The only issue I have is that my A/C will not work, due to a belt issue. The routing I've seen online looks like this -

    DSC00254.JPG

    However the tensioner on my car for the a/c will only move downward, not upward. Therefore the belt cannot go underneath the idler, the only way I can see to install it is how I have it -

    drawing.jpg

    I know that there isn't enough tension on the belt, so I'm thinking I need to go get a smaller one. But here's what's weird - everything spins fine while the engine is running, but when I turn on the A/C the belt seems to stop and not want to turn. I wouldn't think the A/C pump was seized since things are moving fine without the a/c turned on. Anyone have some insight?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    darkman's Avatar
    darkman is offline Cadillac Owners Master
    Automobile(s): 2005 CTS-V
    Join Date
    Nov 2005
    Location
    Spring, Texas
    Posts
    8,208

    Re: UDP install issue

    The routing shown in your drawing is correct. It could be that the tensioner is failing no longer supplies sufficient tension when the AC is turned on as it introduces increased resistance.

  4. #3
    darien99's Avatar
    darien99 is offline Cadillac Owners Fanatic
    Automobile(s): none
    Join Date
    Dec 2005
    Location
    Hazel Park, MI
    Age
    33
    Posts
    194

    Re: UDP install issue

    That was also a thought, I'll try a smaller belt first to see if that remedies the problem. Unfortunately that means taking it back off.

  5. #4
    darien99's Avatar
    darien99 is offline Cadillac Owners Fanatic
    Automobile(s): none
    Join Date
    Dec 2005
    Location
    Hazel Park, MI
    Age
    33
    Posts
    194

    Re: UDP install issue

    For those interested - a new belt solved the problem. The belt that shipped was labeled as a 37" but it must be longer than that because the 36.5 belt I replaced it with is much smaller.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum