Engine Idle Question
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
2004-2007 Cadillac CTS-V Performance Mods Discussion, Engine Idle Question in Cadillac CTS-V Series Forum - 2004 - 2007; I am just trying to find out if this is "normal" behavior which could be attributed to the heavy flywheel ...
  1. #1
    Caditude's Avatar
    Caditude is offline Cadillac Owners Member
    Automobile(s): 2005 Platinum Cadillac CTS-V
    Join Date
    Mar 2007
    Location
    Jacksonville, FL
    Posts
    75

    Engine Idle Question

    I am just trying to find out if this is "normal" behavior which could be attributed to the heavy flywheel in our cars. Here is my issue. Car idles fine (except for some shaking due to broken motor mounts). When I am slowing down and the engine is returning to idle (out of gear) it tries to go 100 or 200 rpm below where it usually idles, at 700 rpm, and then returns to the 700 rpm idle. It did this before and after I installed a W4M tuned PCM.

    Is this normal?

    Is this something I could have W4M fix with the tune?

    Thanks for any info!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    nmaier2201's Avatar
    nmaier2201 is offline Cadillac Owners Connoisseur
    Automobile(s): 2006 CTS-V
    Join Date
    Aug 2007
    Location
    Chicago, IL
    Posts
    1,420

    Re: Engine Idle Question

    You got to push the clutch pedal in a little faster... no waiting till the 4000lb monster almost kills the engine. j/k ( i know I know you said it was out of gear... but I laughed at myself anyways)

    The only think I can add is my car does not do that.

  4. #3
    lollygagger8's Avatar
    lollygagger8 is offline Cadillac Owners Connoisseur
    Automobile(s): Platinum 2004 CTS-V
    Join Date
    Apr 2008
    Location
    Indiana
    Posts
    4,929

    Re: Engine Idle Question

    Not normal.....is your car throwing any codes?

    Your throttle body position sensor might be shot? <- guessing

  5. #4
    Caditude's Avatar
    Caditude is offline Cadillac Owners Member
    Automobile(s): 2005 Platinum Cadillac CTS-V
    Join Date
    Mar 2007
    Location
    Jacksonville, FL
    Posts
    75

    Re: Engine Idle Question

    No codes. I am bringing it in for motor mounts soon and will have them check this out as well.

  6. #5
    lollygagger8's Avatar
    lollygagger8 is offline Cadillac Owners Connoisseur
    Automobile(s): Platinum 2004 CTS-V
    Join Date
    Apr 2008
    Location
    Indiana
    Posts
    4,929

    Re: Engine Idle Question

    If it did it before and after the tune, I would definitely look at the throttle body. Sounds like the sensor/motor is bad that opens/closes the blade.

  7. #6
    Caditude's Avatar
    Caditude is offline Cadillac Owners Member
    Automobile(s): 2005 Platinum Cadillac CTS-V
    Join Date
    Mar 2007
    Location
    Jacksonville, FL
    Posts
    75

    Re: Engine Idle Question

    Bringing this back up.

    I had the mounts installed (Under Extended Warranty ) Shake is gone.

    Dealer checked out the low idle situation and gave me the proverbial "Unable to duplicate customer concern".

    I cleaned the throttle body and seafoamed the engine, but the problem still persists.

    I have an Aeroforce gauge in the car and it is showing a Throttle Percent of 4 when my foot is completely off the gas pedal. Does this sound normal?

    It almost seems like a vaccum leak although I havent been able to find one.

    Any ideas?

  8. #7
    ichpen's Avatar
    ichpen is offline Cadillac Owners Connoisseur
    Join Date
    May 2008
    Location
    Toronto, Ontario, Canada
    Posts
    1,383

    Re: Engine Idle Question

    Have you tried the idle relearn procedure in the FAQ? Maybe the TPS lost idle.

  9. #8
    Caditude's Avatar
    Caditude is offline Cadillac Owners Member
    Automobile(s): 2005 Platinum Cadillac CTS-V
    Join Date
    Mar 2007
    Location
    Jacksonville, FL
    Posts
    75

    Re: Engine Idle Question

    Performed the Idle Relearn procedure from the FAQ yesterday. It seems to have helped some, but not totally.

    Any other ideas?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting