Maggie spins but I have no boost!!!!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 5 1 2 3 4 5 LastLast
Results 1 to 15 of 72
2004-2007 Cadillac CTS-V Performance Mods Discussion, Maggie spins but I have no boost!!!! in Cadillac CTS-V Series Forum - 2004 - 2007; Okay I drove the car to work today just fine. She ran like a champ. Start her up and leave ...
  1. #1
    ctsv154's Avatar
    ctsv154 is offline Cadillac Owners Connoisseur
    Automobile(s): 04 CTS-V with a little hp persuasion device
    Join Date
    Oct 2007
    Age
    29
    Posts
    4,158

    Maggie spins but I have no boost!!!!

    Okay I drove the car to work today just fine. She ran like a champ. Start her up and leave work and I notice she's feeling a little sluggish once I get on the road. I roll into it and I have no boost. I checked all the belts and everything is on and spinning. The belt on the back of the blower is on and is spinning the input shaft on the blower but I have no whine, no boost, no nothing! I'm thinking something broke between the input shaft and what spins the rotors. I guess I'll be pulling the blower of tomorrow sometime to investigate. Hopefully its under warranty???

    Thoughts, concerns??? I never heard anything break, no weird noises leading up to it, nothing. Just boost, then no boost. Car idles fine and runs fine other than the fact that the engine is about 8.4:1 with no boost and she runs like a turd! lol No high idle, no leaks that I can hear. It sounds like the rotors are not spinning at all but like I said, I will investigate more when its day light.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Twitch's Avatar
    Twitch is offline Cadillac Owners Connoisseur
    Automobile(s): '05 CTS-V, '00 SLS, 98 SLS, 89 Eldo, '80 Eldo
    Join Date
    Mar 2006
    Location
    NYC
    Age
    43
    Posts
    3,988

    Re: Maggie spins but I have no boost!!!!

    Check the bypass valve (drivers side, behind TB).
    Good luck

  4. #3
    rand49er's Avatar
    rand49er is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2005 CTS-V, 2011 Cruze 1.4T 6MT
    Join Date
    Jan 2005
    Location
    South Lyon, MI
    Age
    65
    Posts
    13,263

    Re: Maggie spins but I have no boost!!!!

    Quote Originally Posted by Twitch View Post
    Check the bypass valve (drivers side, behind TB).
    Good luck
    Tony beat me to it. If the rear belt hasn't fallen off, then I'll bet that bypass valve is staying open.
    '05 CTS-V, Maggie, Kooks, Hotchkis, Ground Control, Corsa, B&M, DSS/Hendrix, Full 3M Clear Bra, Autovation, V Headrests, CTS Console, STS-V 55w Fogs, Black Vette FRCs, Specter Werkes, Katech LS9 Clutch, SS Brake Lines, Heavymetals U-Turn Fuel Line Eliminator, Momo Combat Evo Shift Knob, Wldwhl Clear Sidemarkers, Linea Corse LC855 Wheels or OEM wheels w/'06-'07 Center Caps, plus a couple more. 472 RWHP/411 RWTQ (Mustang Dyno).

  5. #4
    CTSV_510's Avatar
    CTSV_510 is offline Cadillac Owners Master
    Automobile(s): '06 Z06, '05 CTS-V 453rwhp/434rwtq (sold)
    Join Date
    Jan 2008
    Location
    West Chester, PA
    Age
    31
    Posts
    5,334

    Re: Maggie spins but I have no boost!!!!



    I doubt something actually broke and is preventing the rotors from spinning. If that was the case, chances are you would be hearing some very funny noises coming from it. The bypass valve actuator is the likely culprit.

    FYI, the warranty is only good for the original owner, it doesn't transfer.

  6. #5
    CTSV_510's Avatar
    CTSV_510 is offline Cadillac Owners Master
    Automobile(s): '06 Z06, '05 CTS-V 453rwhp/434rwtq (sold)
    Join Date
    Jan 2008
    Location
    West Chester, PA
    Age
    31
    Posts
    5,334

    Re: Maggie spins but I have no boost!!!!

    Here are some inside pics just for the heck of it:






  7. #6
    rand49er's Avatar
    rand49er is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2005 CTS-V, 2011 Cruze 1.4T 6MT
    Join Date
    Jan 2005
    Location
    South Lyon, MI
    Age
    65
    Posts
    13,263

    Re: Maggie spins but I have no boost!!!!

    Great pics of maggie guts, Tom. Obviously, you had the occasion to open 'er up, I see.
    '05 CTS-V, Maggie, Kooks, Hotchkis, Ground Control, Corsa, B&M, DSS/Hendrix, Full 3M Clear Bra, Autovation, V Headrests, CTS Console, STS-V 55w Fogs, Black Vette FRCs, Specter Werkes, Katech LS9 Clutch, SS Brake Lines, Heavymetals U-Turn Fuel Line Eliminator, Momo Combat Evo Shift Knob, Wldwhl Clear Sidemarkers, Linea Corse LC855 Wheels or OEM wheels w/'06-'07 Center Caps, plus a couple more. 472 RWHP/411 RWTQ (Mustang Dyno).

  8. #7
    CTSV_510's Avatar
    CTSV_510 is offline Cadillac Owners Master
    Automobile(s): '06 Z06, '05 CTS-V 453rwhp/434rwtq (sold)
    Join Date
    Jan 2008
    Location
    West Chester, PA
    Age
    31
    Posts
    5,334

    Re: Maggie spins but I have no boost!!!!

    Hell no! I would be very uncomfortable pulling my daily driver apart like that.

    Plus I wouldn't have done that without showing you guys every step! I got these from the ls1gto forum. They've got TONS of maggie info over there.

  9. #8
    ctsv154's Avatar
    ctsv154 is offline Cadillac Owners Connoisseur
    Automobile(s): 04 CTS-V with a little hp persuasion device
    Join Date
    Oct 2007
    Age
    29
    Posts
    4,158

    Re: Maggie spins but I have no boost!!!!

    Cool pics those are great. Thanks for the info. I played with the bypass last night but it was dark and I could not see well. I just woke up and haven't looked at anything yet so. So the bypass sticking open would prevent you from building 0 boost? I thought I would see something but I guess its possible. Maybe the diaphragm went bad and it cant pull closed? IDK I'll go look around.

  10. #9
    ctsv154's Avatar
    ctsv154 is offline Cadillac Owners Connoisseur
    Automobile(s): 04 CTS-V with a little hp persuasion device
    Join Date
    Oct 2007
    Age
    29
    Posts
    4,158

    Re: Maggie spins but I have no boost!!!!

    Well guys unfortunately I think my first diagnosis was right. I pulled the intake tube and shoved a rod up through the TB and I can spin the rotors with no effort at all. Didn't hear any thing weird when I spun the rotors and they were smooth, just not supposed to spin with all the belts still on. Anybody have magnusons number handy?

  11. #10
    CTSV_510's Avatar
    CTSV_510 is offline Cadillac Owners Master
    Automobile(s): '06 Z06, '05 CTS-V 453rwhp/434rwtq (sold)
    Join Date
    Jan 2008
    Location
    West Chester, PA
    Age
    31
    Posts
    5,334

    Re: Maggie spins but I have no boost!!!!

    Hmm....

    They're closed for the weekend.

    (805) 642-8833 - Phone

    http://www.magnacharger.com/contactus.htm

  12. #11
    darkman's Avatar
    darkman is offline Cadillac Owners Master
    Automobile(s): 2005 CTS-V
    Join Date
    Nov 2005
    Location
    Spring, Texas
    Posts
    7,001

    Re: Maggie spins but I have no boost!!!!

    Are those pulleys keyed?

  13. #12
    SkullV's Avatar
    SkullV is offline Cadillac Owners Connoisseur
    Automobile(s): NONE
    Join Date
    Mar 2007
    Location
    Downtown Chicago
    Posts
    3,847

    Re: Maggie spins but I have no boost!!!!

    What's with these Maggies? It seems like almost everyone that puts one on has problems! Randy are you the only one who has been pretty stable the whole time?

  14. #13
    rand49er's Avatar
    rand49er is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2005 CTS-V, 2011 Cruze 1.4T 6MT
    Join Date
    Jan 2005
    Location
    South Lyon, MI
    Age
    65
    Posts
    13,263

    Re: Maggie spins but I have no boost!!!!

    Quote Originally Posted by SkullV View Post
    What's with these Maggies? It seems like almost everyone that puts one on has problems! Randy are you the only one who has been pretty stable the whole time?
    I think there's an element of hearing only bad news about maggies and very little good. Personally, I did have my bypass valve give me a problem when I had the car dyno'd in early May '08 (just before V-Day I). Ted, I think the guys who dyno'd it screwed it up, though, to be honest. I epoxied it but had Magnuson 2nd-day air a new one to me just in case. Put it on the day before leaving for Summit Point. Whew!

    Going back to the problem at hand, I think vacuum holds the diaphram in the open position allwing the bypass to bypass air directly into the ports. This occurs at low throttle openings, hence higher vac. Only when there's much less vacuum (< ~ 5ish mm Hg?) like at high throttle openings does the diaphram start to close and allow boost to start coming on. I believe the default situation is no bypass and only boost if, say, the diaphram quits working which is not what's going on here. If it is the diaphram sticking open, it'd have to be bound up so the internal spring cannot push it back closed which ALLOW boost conditions to occur. I'm thinking this may be something else ... something else a bit more serious.

    (Hopefully that made sense.)

    The rear belt is okay? If so, then could the rotors be somehow disconnected from the rear pulley thus not being driven by it? Did a keyway break or a key fall out as suggested by darkman?
    '05 CTS-V, Maggie, Kooks, Hotchkis, Ground Control, Corsa, B&M, DSS/Hendrix, Full 3M Clear Bra, Autovation, V Headrests, CTS Console, STS-V 55w Fogs, Black Vette FRCs, Specter Werkes, Katech LS9 Clutch, SS Brake Lines, Heavymetals U-Turn Fuel Line Eliminator, Momo Combat Evo Shift Knob, Wldwhl Clear Sidemarkers, Linea Corse LC855 Wheels or OEM wheels w/'06-'07 Center Caps, plus a couple more. 472 RWHP/411 RWTQ (Mustang Dyno).

  15. #14
    heavymetals's Avatar
    heavymetals is offline Cadillac Owners Master
    Automobile(s): 05 maggied CTS-V, 03 maggied Z06
    Join Date
    Nov 2004
    Posts
    8,634

    Re: Maggie spins but I have no boost!!!!

    Quote Originally Posted by SkullV View Post
    What's with these Maggies? It seems like almost everyone that puts one on has problems! Randy are you the only one who has been pretty stable the whole time?
    Both mine have been very good.

    I had Magnusson rebuild the one on my V, but that was pretty painless as I just pulled it off and drove it out there.

    Also, you probably won't hear alot of positive as that is just the way information flows.

    Everybody sure wants to be heard when they bitch though.

    (You should hear my parrot bitch!)

  16. #15
    ctsv154's Avatar
    ctsv154 is offline Cadillac Owners Connoisseur
    Automobile(s): 04 CTS-V with a little hp persuasion device
    Join Date
    Oct 2007
    Age
    29
    Posts
    4,158

    Re: Maggie spins but I have no boost!!!!

    Okay I pulled the blower. Actually only took about 30 minutes. It is a definite internal failure. Everything on the outside looks great. No loose pulleys, nothing. Everything spins except the rotors. I'm dying to tear it apart but I'd hate to pull it apart to have magnuson deny anything since I split the case.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting