Service Stability System issue.
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
2004-2007 Cadillac CTS-V General Discussion Discussion, Service Stability System issue. in Cadillac CTS-V Series Forum - 2004 - 2007; I've been looking for info everywhere on google and haven't found much luck. I have an 04 CTS-V completely stock ...
  1. #1
    ninnyCTSV is offline Cadillac Owners Member
    Automobile(s): 04 CTS-V
    Join Date
    Jun 2013
    Location
    Moreno Valley, CA
    Age
    26
    Posts
    1

    Service Stability System issue.

    I've been looking for info everywhere on google and haven't found much luck. I have an 04 CTS-V completely stock other than a cags delete. Lately I've been having an issue with the Service Stability System message coming on, but it's causing the driverside front brake to engage. So much that it causes the car to swerve. I've checked for any noticeable issues but have yet to find anything. Sometimes it shows the message the second I turn the car on and other times while i'm driving, and sometimes even not at all. I'm hoping someone might be able to point me in the right direction so I can get this taken care of

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    voodoochikin04's Avatar
    voodoochikin04 is offline Cadillac Owners Fanatic
    Automobile(s): 2003 cts, 2004 Cts-v
    Join Date
    Nov 2012
    Location
    Norfolk, NE (eastern Nebraska)
    Age
    29
    Posts
    305

    Re: Service Stability System issue.

    I had a similiar issue, where it would say service stability system right when id start the car. Sometimes it would say it when I had steering wheel turned all the way one direction while backing out of a parking space.. check all the wired clips at each wheel... for any breaks or bare wires. Then unplugg and reconnect all the plugs for all 4 wheels. doing that, fixed my problem. Also might want to have all the codes cleared, and then disconnect/reconnect the plugs.

  4. #3
    odla's Avatar
    odla is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac platinum 04 & Blk 05 cts-v
    Join Date
    Nov 2006
    Location
    miami ,Fl
    Posts
    2,074

    Re: Service Stability System issue.

    Do a search on this forum and you should find your answer. It has been gone over a lot here. There are a few possible causes.

  5. #4
    stever06 is offline Cadillac Owners Member
    Automobile(s): 2004 cts-v
    Join Date
    Apr 2013
    Location
    schaumburg IL
    Age
    45
    Posts
    39

    Re: Service Stability System issue.

    yes do the search, I had the same problem as you I had to replace my swps steering wheel positioning sensor. the sensor is on the steering column after I replaced mine (there is a write up for this) it has not gone on sense.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting