Recurring lean codes (bank 1 and 2) after K&N filter "recharge" (clean & re-oil)
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7
2004-2007 Cadillac CTS-V General Discussion Discussion, Recurring lean codes (bank 1 and 2) after K&N filter "recharge" (clean & re-oil) in Cadillac CTS-V Series Forum - 2004 - 2007; Hey guys. I have a K&N FIPK II installed and decided to "recharge" the filter a couple months ago. Fresh ...
  1. #1
    WesH8398's Avatar
    WesH8398 is offline Cadillac Owners Enthusiast
    Automobile(s): 2006 CTS-V
    Join Date
    Apr 2010
    Location
    Sarnia, Ontario, Canada
    Age
    32
    Posts
    786

    Recurring lean codes (bank 1 and 2) after K&N filter "recharge" (clean & re-oil)

    Hey guys. I have a K&N FIPK II installed and decided to "recharge" the filter a couple months ago. Fresh after "recharge" I was getting MAF codes and found out that I definitely over-oiled the filter. I bought some MAF cleaner and cleaned it a couple times, which got rid of the MAF code. BUT...since then, I've been getting bank 1 and 2 lean codes that keep popping up. I thought they were maybe residual codes from the over-oiling so I've cleared them 4 or 5 times now ... but they keep coming back.

    I've checked all the intake tube connections, snugged things up a number of times, and also cleaned the MAF a 3rd time...all to no avail. Here's the "freezeframe" data from my OBDII code reader...






    Anyone have any ideas of what would be the most likely culprit? Could it be a bunged up fuel filter? Bigger issue(s)?

    Thanks in advance for any help.


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    robojesus is offline Banned
    Automobile(s): of
    Join Date
    Aug 2012
    Location
    gay
    Posts
    184

    Re: Recurring lean codes (bank 1 and 2) after K&N filter "recharge" (clean & re-oil)

    get a new MAF from advance auto, if that fixes it, order a nice AC Delco, and replace it with that, and return the other one.

    ----------

    this is assuming you already checked everything for a vacuum leak.

  4. #3
    WesH8398's Avatar
    WesH8398 is offline Cadillac Owners Enthusiast
    Automobile(s): 2006 CTS-V
    Join Date
    Apr 2010
    Location
    Sarnia, Ontario, Canada
    Age
    32
    Posts
    786

    Re: Recurring lean codes (bank 1 and 2) after K&N filter "recharge" (clean & re-oil)

    Thanks for the response. Would you say it's plausible that the MAF could be causing the lean codes, but not a code more directly related to the MAF itself (as well as the lean codes)? Could it just need another cleaning, maybe? Or if that were the case, would I be getting a more direct MAF code?
    I've had the intake tubing off and on a hand full of times now, and have been really careful to make sure that everything is secured well and there aren't any areas that could cause leaks...so unless its a leak somewhere past the intake tubing, I'm pretty sure that's not the issue.
    Also, it seems that every time I clear the codes it takes longer for it to reappear too...would this be indicative of anything?

  5. #4
    Jeff James is offline Cadillac Owners Member
    Automobile(s): 07 V1
    Join Date
    Oct 2011
    Age
    54
    Posts
    73

    Re: Recurring lean codes (bank 1 and 2) after K&N filter "recharge" (clean & re-oil)

    I see you have cleaned the MAF a number of times. Have you re-cleaned and barely oiled the filter? Our Mafs do NOT like too much oil. The best CAI filters don't use oil for filtering.

  6. #5
    BigDaddy-V is offline Cadillac Owners Fanatic
    Automobile(s): CTS-V 04 LS6
    Join Date
    Mar 2013
    Location
    Wylie, TX
    Posts
    333

    Re: Recurring lean codes (bank 1 and 2) after K&N filter "recharge" (clean & re-oil)

    It could also be something on the fuel side clogging it up and not enough getting there. Pinched line, clogged filter, or the pump not pumping enough. A lot of things. To look at and think of when you are running that lean.

    BDV

  7. #6
    WesH8398's Avatar
    WesH8398 is offline Cadillac Owners Enthusiast
    Automobile(s): 2006 CTS-V
    Join Date
    Apr 2010
    Location
    Sarnia, Ontario, Canada
    Age
    32
    Posts
    786

    Re: Recurring lean codes (bank 1 and 2) after K&N filter "recharge" (clean & re-oil)

    Thanks again for the replies.

    This weekend I removed the filter/MAF and re-cleaned both of them a couple times. I let the filter dry overnight (on a fan), re-oiled it this morning (VERY lightly this time), and re-installed everything. We'll see what happens from here. If I get the codes again, I'll have to start looking into other things. The fuel filter may need changing anyway, so that'll be where I start. Got a set of fuel line disconnect tools today, just in case.

  8. #7
    WesH8398's Avatar
    WesH8398 is offline Cadillac Owners Enthusiast
    Automobile(s): 2006 CTS-V
    Join Date
    Apr 2010
    Location
    Sarnia, Ontario, Canada
    Age
    32
    Posts
    786

    Re: Recurring lean codes (bank 1 and 2) after K&N filter "recharge" (clean & re-oil)

    Well...been about a week and no codes popping up. I'm going to plug the reader in toniight to check for pending codes, but I'm thinking all is well now that the excess filter oil has been taken care of. Thanks guys.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting