Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22

Thread: Bad Trans Mount? Pics

  1. #16
    jeremy107 is offline Cadillac Owners Member
    Automobile(s): CTS-V
    Join Date
    May 2013
    Age
    28
    Posts
    48

    Re: Bad Trans Mount? Pics

    Quote Originally Posted by SevillianSTS View Post
    Found this on google: http://www.google.com/search?q=revsh...l%3B1023%3B612 There is a thread somewhere that revshift posted before and after pictures of the insert installed on a brand new OEM mount. There was no difference in height once the block was installed into the NEW mount.
    Hmmm nice find there, looks like the block does the exact same thing as a brand new mount costing 100$ more!! Good to know!

  2. #17
    Becker's Avatar
    Becker is offline Cadillac Owners Fanatic
    Automobile(s): 2006 black with tan V
    Join Date
    May 2013
    Age
    31
    Posts
    391

    Re: Bad Trans Mount? Pics

    that is very informative, i will be inspecting my trans mount tomorrow

  3. #18
    FoD is offline Cadillac Owners Fanatic
    Automobile(s): 05 CTS-V
    Join Date
    Mar 2012
    Location
    Charlotte, NC
    Posts
    250

    Re: Bad Trans Mount? Pics

    My mount looked identical to yours. Revshift block inserted back in October 2012...game changer!

  4. #19
    V for victory is offline Cadillac Owners Fanatic
    Automobile(s): 2012 CTS-V, 2013 Dodge Durnago R/T
    Join Date
    Mar 2011
    Location
    Levittown, PA
    Age
    51
    Posts
    243

    Re: Bad Trans Mount? Pics

    The RS block completely corrected my issues with going into reverse I was having, my mount didn't look 1/10th as bad as yours, I cant even imagine how your getting into gear with that thing....good luck should be a easy fix and major improvement.

  5. #20
    jeremy107 is offline Cadillac Owners Member
    Automobile(s): CTS-V
    Join Date
    May 2013
    Age
    28
    Posts
    48

    Re: Bad Trans Mount? Pics

    There is hope!!

  6. #21
    brngrhd is offline Cadillac Owners Member
    Automobile(s): 2004 cts-v
    Join Date
    Apr 2013
    Age
    37
    Posts
    93

    Re: Bad Trans Mount? Pics

    Why buy a new mount and a RS insert? Why not just buy the CS mount?

    ----------

    Just went and looked at the pictures again...... I'd fix the leak that saturated the mount in oil and buy a CS mount. The rubber on your mount is so bad installing a RS insert will fix only part of the issue

  7. #22
    jonathan2169's Avatar
    jonathan2169 is offline Cadillac Owners Member
    Automobile(s): 2011 CTS-V and 2004 CTS-V
    Join Date
    Apr 2013
    Age
    41
    Posts
    86

    Re: Bad Trans Mount? Pics

    My 2 cents - just installed the Revshift trans mount insert on Sunday and the difference was immediate. I had limited clearance under jack stands and a jack under the trans and got it done in less than 20min including jacking. Looks like it will not fit and then surprises u when it does. I wish I could say I have this issue often. LOL

    Use the grease; made it pretty easy.

Page 2 of 2 FirstFirst 12

Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum