Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

+ Reply to Thread
Results 1 to 3 of 3

Thread: Sub Install FAIL (...HELP?)

  1. #1
    LS6Steve is offline Cadillac Owners Fanatic
    Automobile(s): 2004 CTS-V
    Join Date
    Jun 2011
    San Jose, CA

    Sub Install FAIL (...HELP?)

    Wanted to add an amp/sub to my 04 V with Bose Nav.

    Tapped into fuse block 12V power under rear seat, grounded to one of the back seat mount bolts, used a Navone 2ch LOC tapped into the rear stock sub hi-level wires (just used the L+ and L-). I have a remote gain control knob (potentiometer) on my oldie-but-goody Phoenix Gold 300wrms amp running a 12W3 in a wedge box. I've used this all in other cars and it sounds great.

    Fired it up...

    Bass lowers in volume as I turn up the main volume. I knew Caddy stock systems did this, but I would SWEAR i've read that by using the Navone 2ch (instead of the hi-level inputs on my amp) that I would overcome this and have a steady signal to my amp RCA.

    I emailed Dave N, he said it seems like the polarity is backwards. I double checked the whole system and it is wired correctly. I swapped the +/- on the hi level input to the LOC for shitsngrins but it acted the same. Good bass at 1-50% volume but when I turn it up it fades out and just sounds like crap.

    What did I do wrong? Any ideas?

    Thanks ahead...

  2. #2
    heavymetals's Avatar
    heavymetals is offline Cadillac Owners Master
    Automobile(s): 05 maggied CTS-V, 03 maggied Z06
    Join Date
    Nov 2004

    Re: Sub Install FAIL (...HELP?)

    Try ditching the LOC and use the high level inputs.

  3. #3
    perfect's Avatar
    perfect is offline Cadillac Owners Connoisseur
    Automobile(s): 2005 Cadillac CTS-V Platinum
    Join Date
    May 2008
    Kansas City

    Re: Sub Install FAIL (...HELP?)

    I installed my system with the Navone (as have many others) and have not had this problem.

+ Reply to Thread


Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum