Both key fobs in operable and all 4 TPMS sensors showing --- - Page 3
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 3 of 3 FirstFirst 1 2 3
Results 31 to 43 of 43
2004-2007 Cadillac CTS-V General Discussion Discussion, Both key fobs in operable and all 4 TPMS sensors showing --- in Cadillac CTS-V Series Forum - 2004 - 2007; I'm not quite sure if this happened after I got the tint. I think it did, but it's been almost ...
  1. #31
    junoreactor's Avatar
    junoreactor is offline Cadillac Owners Fanatic
    Automobile(s): 05 Maggied CTS-V
    Join Date
    Jul 2009
    Location
    Central PA
    Posts
    201

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    I'm not quite sure if this happened after I got the tint. I think it did, but it's been almost half a year since I got tinted. The intermittant problems could have started before, but I cannot recall now. The complete failure is recent though. I just tried holding the remote up near the dome light and nothing happened. Also tried holding the holding the female end of the wire to no avail. Held the metal arm part of the module that is mounted with the bolt. Nothing. I'll try to resand the connectors tonight.

  2. #32
    RoverGuy7 is offline Cadillac Owners Member
    Automobile(s): 05 CTS-V
    Join Date
    Jun 2010
    Posts
    62

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    i dont think cleaning up the connections will help. if your problem is because of reception its going to be contact from the window grid to the snap itself, not the wire that connects to the module

  3. #33
    junoreactor's Avatar
    junoreactor is offline Cadillac Owners Fanatic
    Automobile(s): 05 Maggied CTS-V
    Join Date
    Jul 2009
    Location
    Central PA
    Posts
    201

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    Cleaning the connections didn't help.

  4. #34
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    46
    Posts
    11,062

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    The snaps are only for the am/fm antenna grids.
    They should have no affect on RKE range or operation.

    Have you gotten to the power connection to the antenna module?
    I can look later to find the source of power to the module and you should double check it.
    If the radio reception is nil, and the snaps are all on then you likely have an issue with the tint or the antenna module is not getting powered.

  5. #35
    junoreactor's Avatar
    junoreactor is offline Cadillac Owners Fanatic
    Automobile(s): 05 Maggied CTS-V
    Join Date
    Jul 2009
    Location
    Central PA
    Posts
    201

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    I'm not sure which wire is the power one or where the end that doesn't connect to the module is located. That'd be helpful if you can look later and get back to me on which wire to check.

  6. #36
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    46
    Posts
    11,062

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    You have to access the module, there is I think a three wire connection on the left side of the module. The red/white wire is battery power from a hot at all times fuse that is in the left rear fuse panel (under the rear seat) labeled TRUNK DR RELEASE.
    From a good ground you should get a test light to light when touching the terminal on that circuit.
    The Orange wire is a switch on signal from the radio for FM and the other is a class 2 wire that connects the module to the data bus.
    (purple)
    Make sure the red/white wire is hot.
    Let me know what you find.

  7. #37
    junoreactor's Avatar
    junoreactor is offline Cadillac Owners Fanatic
    Automobile(s): 05 Maggied CTS-V
    Join Date
    Jul 2009
    Location
    Central PA
    Posts
    201

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    I had the car in for service while I was recovering from some sinus/bronchial infection last week. While it was in there the techs looked over the TPMS system and changed the antenna module in the roof. I never got around to checking the power wire as you mentioned. There is some good news and bad news now. The good news is that my FM reception is now present and I can actually pick up a station outside of the town that it's broadcasting in. The reception isn't the best nor is it really far, but I'm thinking that is tint related at this point. The bad news is that the TPMS sensors are intermittantly going to the --- reading still.

    A couple of days ago, I put my OEM wheels back on for winter and reprogrammed the sensors to the car.

    As it stands now, everything is fine when I start the car. I'm getting all four readings. However, after driving for about 15 mins and up to 20 miles, 3 of the sensors (FL, RL, RR) are dropping out to the --- readings. I cannot tell if they are dropping at the same time as it seems to happen everytime I'm looking at the road and I miss it. They are dropping the readings close to the same time though. Halfway through my 45 min drive home from work I stop at a convenience store to grab a drink. When I come out and start the car back up, usually all the readings are back and correct too. Oh, also as I'm driving in the morning the pressures are slowly rising as the tire heats up from the overnight cold, so I know the TPMS seems to usually be reading correctly.

    Tonight though I had something new happen. Upon leaving work and starting the car my rear left tire was reading at 9psi. I got out and kicked the tire just to be safe. About 5 miles away I stopped at Sheetz to check the pressure with their compressor. I only had the air hose on the tire about 5 seconds. After getting back in the car, the reading at the rear left tire was back up to 30psi like it should be. Then on the ride home on the highway, the same three sensors dropped out again (FL, RL, RR). I stopped at another Sheetz about 20 minutes later and as I sat there the rear left sensor switched from --- to a proper 30psi reading. I went in to grab a snack and when I came back out and restarted the car another sensor was working, with only one showing ---.

    As far as I know, these sensors are the original ones that came with the car in 2005. I saw in some other post that someone was saying that the batteries could be dying and the sensors maybe need replaced. However, the ones on my Veneto wheels were acting strange, but I didn't test them long after the trip to the dealer where they changed the antenna module before I put on my winter wheels. Maybe the sensors I got from Wheeldude were sitting on the shelf for a while though and could be aging as well. I don't know.

    I hope this wasn't too confusing. I feel as it's kind of rambling, but I'm pretty tired from work and can't get my thoughts out much clearer. As always thanks for any help guys.

  8. #38
    Houdini's Avatar
    Houdini is offline Cadillac Owners Connoisseur
    Automobile(s): 2010 CTS-V 6MT, 2007 CTS-V (Sold)
    Join Date
    Nov 2007
    Location
    St. Louis Metro
    Posts
    1,339

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    It does sound like batteries going bad in the sensors.

  9. #39
    junoreactor's Avatar
    junoreactor is offline Cadillac Owners Fanatic
    Automobile(s): 05 Maggied CTS-V
    Join Date
    Jul 2009
    Location
    Central PA
    Posts
    201

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    Still having this issue. I cannot seem to figure this out. I'm not really keen on spending 200 for 4 new sensors. I had the car back to the dealer to get the antenna module in the ceiling replaced and my key fobs are working correctly now. However the pressure readings are still disappearing randomly. The right front though seems to stay constant. Last night while driving home the driver rear sensor started to show 0psi and the Tire symbol illuminated. So I shut the car off and there was no problem. Upon restarting the engine all the readings were back, for a little while at least. I wish there was a GM engineer or something a person could contact to get help. I really don't want to go back to the dealer again and keep throwing money at it. I don't think they have much experience on an issue like this; I'd imagine it's an uncommon occurance.

  10. #40
    Noisycow's Avatar
    Noisycow is offline Cadillac Owners Fanatic
    Automobile(s): 2005 Platinum CTS-V
    Join Date
    Dec 2010
    Location
    Portland OR
    Posts
    102

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    I search for this and found my answer here. My remotes died, the dealer is charging me $450! for the module .... and ... of course the service writer told me over the phone that my TPMS died while in their care and needs fixing. Thank God for the internet and this forum. Of course, they killed my TPMS. Maybe it needs to be driven awhile? This dealer already has tripped up telling me a related issue could not be a fuse. (the rear lock unlocks not working could NOT be a fuse and troubleshooting it would be $180-$360).

    Stealerships, I hate them. I am really pissed, but a friend said 'get used to it, all dealers are the same.'

    Here's a recall note on the STS (not CTS) about the fact that on these Cads the keyless entry and TPMS are built into the same unit.


  11. #41
    RippyPartsDept's Avatar
    RippyPartsDept is offline Hi, I'm Chris - Please Read My Signature
    Automobile(s): 1999 DeVille "Bianca" (white/blue, VIN-Y, 160k)
    Join Date
    Sep 2007
    Location
    Wilmington, NC
    Age
    34
    Posts
    13,837

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    yup, it's a wireless receiver and why have two if you can engineer it with one?

    and not all dealerships are the same...

    i can save you some money on that module
    Chris Heath (RippyPartsDept) is an ASE Certified GM Parts Consultant at
    Rippy is a Cadillac, Hummer, Saturn & Saab dealership - family owned and operated in Wilmington, NC since 1946
    We offer all forum members deals on parts and freight - e: parts@rippyautomotive.com ph: 800-RIPPY-22
    <-- insert standard boilerplate about posts not necessarily representing my employer, etc -->

  12. #42
    bimmer09 is offline Cadillac Owners Member
    Automobile(s): CTS-V
    Join Date
    Dec 2010
    Age
    28
    Posts
    4

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    It happen the same thing to me last day !!!! How did you fix that ??

    Thanks

  13. #43
    bimmer09 is offline Cadillac Owners Member
    Automobile(s): CTS-V
    Join Date
    Dec 2010
    Age
    28
    Posts
    4

    Re: Both key fobs in operable and all 4 TPMS sensors showing ---

    It happen the same thing to me last day !!!
    How did you fix it ???


    ( Zo6PwRd )
    What are the chances, my battery died today so i jumped it. Then when i start the car the service security system came uop oin the nav, the TPMS show --- and the key fobs dont work.

    Thanks

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting