Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 8 of 8

Thread: Please HELP! - Car won't start with either key after installing W4M ecm pcm

  1. #1
    Houdini's Avatar
    Houdini is online now Cadillac Owners Connoisseur
    Automobile(s): 2016 CTS-V, 2010 CTS-V 6MT (Sold), 2007 CTS-V (Sold)
    Join Date
    Nov 2007
    Location
    St. Louis Metro
    Posts
    1,405

    Please HELP! - Car won't start with either key after installing W4M ecm pcm

    I need some help. I purchased ichpen's 06 w4m ecm for my 07. After installing I reconnected the battery and now neighter key will start the car. The nav displays a message saying "starting disabled - remove key". Obviously this is security related. So far, everything I've read indicates either a fried ecm or that it was programmed for his VIN and it will not work with my anti-theft module because it is seeing a different VIN. Any thoughts? I've tried everything I could think of to get these keys to work. Does this ecm need to go back to W4M to have my own VIN programmed? Wonder what he will charge for that?

    After many hours, I slapped my own ecm back in and the car started right up no problem.

    I know someone here can shed some light on this for me. I thought I'd be able to pop it in and go....maybe a case relearn but certainly no security problems...sigh.

  2. #2
    kirchbed's Avatar
    kirchbed is offline Cadillac Owners Fanatic
    Automobile(s): 2004 CTS-V
    Join Date
    Sep 2008
    Location
    Washington, DC
    Posts
    337

    Re: Please HELP! - Car won't start with either key after installing W4M ecm pcm

    You need to send it to w4m and have it programmed with your VIN.

  3. #3
    Houdini's Avatar
    Houdini is online now Cadillac Owners Connoisseur
    Automobile(s): 2016 CTS-V, 2010 CTS-V 6MT (Sold), 2007 CTS-V (Sold)
    Join Date
    Nov 2007
    Location
    St. Louis Metro
    Posts
    1,405

    Re: Please HELP! - Car won't start with either key after installing W4M ecm pcm

    son of a.... thanks. Isn't there a way for these to be VIN unlocked? Is that not safe?

  4. #4
    odla's Avatar
    odla is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac platinum 04 & Blk 05 cts-v
    Join Date
    Nov 2006
    Location
    miami ,Fl
    Posts
    2,372

    Re: Please HELP! - Car won't start with either key after installing W4M ecm pcm

    nope need to send it back.

  5. #5
    AAIIIC's Avatar
    AAIIIC is offline Super Moderator
    Automobile(s): '05 CTS-V
    Join Date
    Aug 2007
    Location
    Where the Navy takes me...
    Posts
    6,463

    Re: Please HELP! - Car won't start with either key after installing W4M ecm pcm

    One of the techs @ Lindsay (Robert) told me when I installed my W4M ECU that if the security key light came on there was a way to "relearn" the immobilizer function. I haven't had any issues, so I've forgotten what he told me, but it was something weird like cycling the key to the ON position 20 times in a minute then hopping on one leg while touching your nose with your index finger. Like I said, I forgot exactly what he told me. Try talking to one of your local dealer techs about how to relearn the security system after an ECU swap. If they won't help, try calling Lindsay Service and ask to talk to Robert (you want the technician Robert - I think there's also a service writer Robert).

    There has to be a way to do it, otherwise dealers would never be able to replace a bad ECU with a new one (which obviously doesn't come off the shelf programmed with a specific VIN).
    '05 Stealth Grey CTS-V, 19x8.5/10" CCW T140s with Toyo Proxes T1 Sports (summer), black Team Dynamics ProRace 1.2 wheels with 275/35-18 R-compounds (track), Hyperblack Rota Torques (winter), KW Variant3s, V2 front brakes, Hotchkis rear sway bar, EPS cam, TEA-ported 243 heads, FAST92 intake w/LS2 TB, JBA Camaro/G8 1-3/4" shorty headers w/JBA cat pipes, Corsa exhaust, UUC motor and tranny mounts, UUC shifter, MAPerformance trailing arms, Specter cradle bushings, etc...

  6. #6
    Houdini's Avatar
    Houdini is online now Cadillac Owners Connoisseur
    Automobile(s): 2016 CTS-V, 2010 CTS-V 6MT (Sold), 2007 CTS-V (Sold)
    Join Date
    Nov 2007
    Location
    St. Louis Metro
    Posts
    1,405

    Re: Please HELP! - Car won't start with either key after installing W4M ecm pcm

    I'm pretty sure dealers have to program any replacement ECM with the car's VIN so that it works with the theft module correctly. I'm going to try to get in touch with W4M to get it programmed with my VIN. I don't want to go to the dealer because I'm still under warranty and I know they won't be nice about a tuned ECM

  7. #7
    peteralan is offline Cadillac Owners Member
    Automobile(s): 2004 cadillac cts 3.6
    Join Date
    Dec 2011
    Age
    34
    Posts
    3

    Re: Please HELP! - Car won't start with either key after installing W4M ecm pcm

    VERY VERY SIMPLE, ON MY THIRD ECM!

    1. Insert ignition key and turn to the “ON” position. Do not attempt to start the engine. Leave
    the key in the “ON” position for approximately 11 minutes. The security light will be steady
    on or flashing for the 11-minute period. Do not proceed to Step 2 until the security light
    turns off or stops flashing.
    2. Turn the ignition switch to the “OFF” position for 30 seconds.
    3. Turn the ignition switch to the “ON” position as in Step 1 for 11 minutes.
    4. Turn the ignition switch to the “OFF” position for 30 seconds.
    5. Turn the ignition switch to the “ON” position as in Step 1 for 11 minutes for a third time.
    6. Turn the ignition switch to the “OFF” position for 30 seconds for a third time.
    7. Turn the ignition switch to the “ON” position for 30 seconds.
    8. Turn the ignition switch to the “OFF” position.
    9. Attempt to start the engine.
    If the engine starts and runs, the relearn is complete.
    Passlock
    Attached Images

  8. #8
    FoD is offline Cadillac Owners Fanatic
    Automobile(s): 05 CTS-V
    Join Date
    Mar 2012
    Location
    Charlotte, NC
    Posts
    250

    Re: Please HELP! - Car won't start with either key after installing W4M ecm pcm

    Yeah...40 minutes to steal a car would make me give up and move onto the next one.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum