Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98). - Page 5
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 5 of 16 FirstFirst 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 ... LastLast
Results 61 to 75 of 228
Like Tree2Likes
2004-2007 Cadillac CTS-V General Discussion Discussion, Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98). in Cadillac CTS-V Series Forum - 2004 - 2007; Any progress?...
  1. #61
    heavymetals's Avatar
    heavymetals is offline Cadillac Owners Master
    Automobile(s): 05 maggied CTS-V, 03 maggied Z06
    Join Date
    Nov 2004
    Posts
    8,659

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Any progress?

  2. #62
    CtsVrod's Avatar
    CtsVrod is offline Cadillac Owners Connoisseur
    Automobile(s): 05 CTS-V / 06 Escalade
    Join Date
    Oct 2007
    Location
    So Cal - Agoura Hills
    Age
    31
    Posts
    1,111

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Nada... It was going off today in traffic again

  3. #63
    Twitch's Avatar
    Twitch is offline Cadillac Owners Connoisseur
    Automobile(s): '05 CTS-V, '00 SLS, 98 SLS, 89 Eldo, '80 Eldo
    Join Date
    Mar 2006
    Location
    NYC
    Age
    43
    Posts
    3,992

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Quote Originally Posted by CtsVrod View Post
    Nada... It was going off today in traffic again
    Unplug that bitch.

  4. #64
    c4ss's Avatar
    c4ss is offline Cadillac Owners Connoisseur
    Automobile(s): 2005 CTS-V, Black
    Join Date
    Jun 2008
    Location
    Northern New Jersey
    Posts
    2,173

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Quote Originally Posted by Twitch View Post
    Unplug that bitch.

    Mine was going off TONIGHT....as in like 60 degree weather. I'm about to unplug it. Where is this sensor again? Thanks.

  5. #65
    Twitch's Avatar
    Twitch is offline Cadillac Owners Connoisseur
    Automobile(s): '05 CTS-V, '00 SLS, 98 SLS, 89 Eldo, '80 Eldo
    Join Date
    Mar 2006
    Location
    NYC
    Age
    43
    Posts
    3,992

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Quote Originally Posted by c4ss View Post
    Mine was going off TONIGHT....as in like 60 degree weather. I'm about to unplug it. Where is this sensor again? Thanks.
    Quote Originally Posted by Twitch View Post
    Just got back from a short ride. At startup, the nav tells you to check your oil level. Press OK once, and it wont bother you till you turn the car off. I did check my level, and its perfect.
    You might be able to get to the plug with the car on the ground, and wheel turned to the left (I had the wheel off anyway). Its on the oil pan, facing the pass wheel.

  6. #66
    c4ss's Avatar
    c4ss is offline Cadillac Owners Connoisseur
    Automobile(s): 2005 CTS-V, Black
    Join Date
    Jun 2008
    Location
    Northern New Jersey
    Posts
    2,173

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Quote Originally Posted by Twitch View Post

    Thanks bud. I'm kind of lazy these days

  7. #67
    nxlr8's Avatar
    nxlr8 is offline Cadillac Owners Fanatic
    Automobile(s): 2004 Platinum CTS-V
    Join Date
    May 2006
    Location
    Aurora, IL
    Posts
    446

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Quote Originally Posted by CtsVrod View Post
    I can make it come on now though... Since I've dealt with it for soo long. Just wait for the Car to Warm up (30+ mins) Hit the Brakes, Turn on AC, Hit the Window Up Buttons, and WA LAH!!! Ding Ding Ding - Pisses me OFF!!
    Did this "trick" and it did the same thing...
    250*, hit the brakes, jumps to 280* in a second.
    Hit both windows down buttons while hitting the brake - Chimes go off!

  8. #68
    Twitch's Avatar
    Twitch is offline Cadillac Owners Connoisseur
    Automobile(s): '05 CTS-V, '00 SLS, 98 SLS, 89 Eldo, '80 Eldo
    Join Date
    Mar 2006
    Location
    NYC
    Age
    43
    Posts
    3,992

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Anybody check their battery voltage? Mine seems to be a little low. Starts at 14+. Then as the car warms up, and I'm using the AC, it drops to +/- 13. I really need to get off my ass, and check those grounds before I waste $$$ on a new battery.
    Keep you guys posted.

  9. #69
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    46
    Posts
    11,062

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Sensor is a 3 wire connector, passenger (right) side oil pan.
    If electrical loads seem to change the reading then it could be a grounding issue.
    I have read a TSB on redoing the ground but have never done one.

  10. #70
    Twitch's Avatar
    Twitch is offline Cadillac Owners Connoisseur
    Automobile(s): '05 CTS-V, '00 SLS, 98 SLS, 89 Eldo, '80 Eldo
    Join Date
    Mar 2006
    Location
    NYC
    Age
    43
    Posts
    3,992

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Hmmm, can TSBs be done out of warranty?

  11. #71
    CTSV_510's Avatar
    CTSV_510 is offline Cadillac Owners Master
    Automobile(s): '06 Z06, '05 CTS-V 453rwhp/434rwtq (sold)
    Join Date
    Jan 2008
    Location
    West Chester, PA
    Age
    31
    Posts
    5,334

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Quote Originally Posted by Twitch View Post
    Hmmm, can TSBs be done out of warranty?
    Sure, but standard labor rate applies.

    The only thing the TSB will get you is a quicker diagnosis.

  12. #72
    Twitch's Avatar
    Twitch is offline Cadillac Owners Connoisseur
    Automobile(s): '05 CTS-V, '00 SLS, 98 SLS, 89 Eldo, '80 Eldo
    Join Date
    Mar 2006
    Location
    NYC
    Age
    43
    Posts
    3,992

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Quote Originally Posted by CTSV_510 View Post
    Sure, but standard labor rate applies.

    The only thing the TSB will get you is a quicker diagnosis.
    So in my language, TSB means DIY

  13. #73
    Twitch's Avatar
    Twitch is offline Cadillac Owners Connoisseur
    Automobile(s): '05 CTS-V, '00 SLS, 98 SLS, 89 Eldo, '80 Eldo
    Join Date
    Mar 2006
    Location
    NYC
    Age
    43
    Posts
    3,992

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Quick update.
    I seem to be having charging issues, and a new battery didn't help. So I decided to check the grounds. Did the one on the fender first. Maggie guys should really check this (except Randy). Took off the bolt, and wire brushed everything. Did one behind the drivers side head, but could not get so much as a finger behind the other head. Then I got under the car to check the starter wires. Took one wire off. It was pretty bad, but I cleaned it up best I could.
    Plugged the sensor in, and drove to work this morning. It was a cool morning, and a short ride. But I had everything on, A/C, lights etc. Oil temps moved around between 210 and low 220s.
    I'll update after I've been on a longer ride.

    Unfortunately, car is still showing low to mid 13v

    Tony

  14. #74
    heavymetals's Avatar
    heavymetals is offline Cadillac Owners Master
    Automobile(s): 05 maggied CTS-V, 03 maggied Z06
    Join Date
    Nov 2004
    Posts
    8,659

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    If you remove the windshield wiper facia (very easy) you can get at the rear of the heads much easier.

    The passenger side is less of a problem if you remove the battery.

  15. #75
    Twitch's Avatar
    Twitch is offline Cadillac Owners Connoisseur
    Automobile(s): '05 CTS-V, '00 SLS, 98 SLS, 89 Eldo, '80 Eldo
    Join Date
    Mar 2006
    Location
    NYC
    Age
    43
    Posts
    3,992

    re: Damn! High Oil Temp and alarms? Here is a fix for it (page 7 post #98).

    Quote Originally Posted by heavymetals View Post
    If you remove the windshield wiper facia (very easy) you can get at the rear of the heads much easier.

    The passenger side is less of a problem if you remove the battery.
    Battery was out. With the wire harness, and some extra Maggie stuff back there, it was too tight.
    I'll see if I fixed the oil temp. Not too worried about that now. Trying to figure out why my voltage doesn't stay at 14 when the car warms up.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting