Coolant loss...
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
2004-2007 Cadillac CTS-V General Discussion Discussion, Coolant loss... in Cadillac CTS-V Series Forum - 2004 - 2007; During the past year accumulating approximately 10k miles, the DIC has indicated "low coolant level" twice. Is this typical??? TIA, ...
  1. #1
    pimpcaddy's Avatar
    pimpcaddy is offline Cadillac Owners Enthusiast
    Automobile(s): 2005 Platinum/Ebony
    Join Date
    Dec 2004
    Location
    San Ramon, CA
    Posts
    501

    Coolant loss...

    During the past year accumulating approximately 10k miles, the DIC has indicated "low coolant level" twice. Is this typical???

    TIA,

    Dave

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    1QUICKV is offline Cadillac Owners Enthusiast
    Automobile(s): CTS-V SERIES
    Join Date
    Jul 2006
    Location
    BROOKLYN
    Age
    26
    Posts
    699

    Re: Coolant loss...

    Your rad is leaking at the bottom where the lower radiator hosed connects. Leaking from seam.

  4. #3
    50 4Ever's Avatar
    50 4Ever is offline Cadillac Owners Connoisseur
    Automobile(s): 2007 CTS-V (Thunder Grey)
    Join Date
    Dec 2005
    Location
    Sacramento Kalifornia
    Age
    64
    Posts
    1,651

    Re: Coolant loss...

    Last summer I got that message, filled up the reservoir and everythings been fine since. Now watch, I'll probably get that message tomorrow. Oh, just turned over 29K.


  5. #4
    Playdrv4me's Avatar
    Playdrv4me is offline Cadillac Owners 10000+ Posts
    Automobile(s): 1992 STS / 2005 MB G500 / 2008 Mini Cooper Clubman S
    Join Date
    Nov 2003
    Location
    TPA / STL / ICT / SAT
    Posts
    11,684

    Re: Coolant loss...

    Unfortunately, non Northstar Caddies seem to pick up this very bad habit from their N* counterparts when they are sitting together at the dealers lot. My Escalade has done this to me twice since Ive owned it as well.

    Id look into the connection mentioned above as it seems the most likely cause. I just keep mine filled.

  6. #5
    vcaddy is offline Cadillac Owners Member
    Join Date
    Jul 2006
    Posts
    67

    Re: Coolant loss...

    I had the same thing, two "Low coolant" messages in the past 3000 miles or so. I always top off the reservoir and forget about it because I have not noticed any fluid on the ground. I think I will check the radiator seam. Thanks for the tip!!

  7. #6
    G--'s Avatar
    G--
    G-- is offline Cadillac Owners Fanatic
    Automobile(s): 05 CTS-V Black;08 Yukon Denali
    Join Date
    Jul 2006
    Location
    DFW area, TX
    Posts
    276

    Re: Coolant loss...

    Quote Originally Posted by 1QUICKV View Post
    Your rad is leaking at the bottom where the lower radiator hosed connects. Leaking from seam.

    Had the exact same issue, my dealer replaced the radiator under warranty, no questions asked. I could be wrong (I did not do a search), but I believe there's a TSB out on this as well....

  8. #7
    The Hog's Avatar
    The Hog is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac CTS-V
    Join Date
    Mar 2007
    Location
    Spokane, WA
    Age
    34
    Posts
    178

    Re: Coolant loss...

    [QUOTE=Playdrv4me;1063823]Unfortunately, non Northstar Caddies seem to pick up this very bad habit from their N* counterparts when they are sitting together at the dealers lot. My Escalade has done this to me twice since Ive owned it as well.

    QUOTE]

    Hell, just reading the word "Northstar" make me want to leak a little bit.

  9. #8
    trukk's Avatar
    trukk is offline Cadillac Owners Master
    Automobile(s): '05 CTS-V, '12 CTS-V Manny Vagon
    Join Date
    Jul 2004
    Location
    Elkridge, MD
    Age
    41
    Posts
    6,073

    Re: Coolant loss...

    I had my radiator replaced once for this.

    I just recently noticed a small leak again, and have the smell of coolant sometimes when I get on it hard.

    the leak itself is pinhole in size. it would take 5+ years to leak all the coolant out I'd think, but still not acceptible.

    I'm surprised this issue re-occured. I thought I had it fixed with the 'new' radiator.


    -Chris
    2005 CTS-V:No Roof|T2+Eibachs|Corsa|UUC:Shifter, 2pc rotors, B-Lines, Motor/Tran Mounts, Diff Bushings|LPE CAI|FFV IntakeTube|Hotchkis Sways|Kooks 1.75 Coated LTs+cats|KARS III |Mamofied Fast90 + NW90|224/228 111+0 XFI/XE-R .609/.588+Dual Springs|ATI 25% UD Pulley|YT 1.7" UltraLites|Melling HiFlow OP|Cloyes Hex Adjust Timing Set|Lucas 42# Flow Matched Injectors|Katech LS9X Twin-Disk ClutchMustang Dyno Tuned (SAE): 412rwhp / 380 rwtq
    2012 CTS-V:No Roof|Wagon|M6|Recaros|Bone stock (for now)

  10. #9
    kgoch is offline Cadillac Owners Fanatic
    Automobile(s): 04 CTS-V
    Join Date
    Jul 2005
    Location
    Mountville, PA
    Age
    67
    Posts
    209

    Re: Coolant loss...

    I had my radiator replaced twice under warrenty. It seems they had a batch of bad radiators. When you rev to over 6,000 rpm it would create to much pressure on the radiator and start leaking at the bottom seam. Since the last radiator i have not had any problems.

  11. #10
    z06bigbird is offline Cadillac Owners Connoisseur
    Automobile(s): Sedan de Ville, CTS
    Join Date
    Mar 2007
    Location
    San Antonio, Tx
    Posts
    4,771

    Re: Coolant loss...

    I don't mind going to the radiator shop. It is a good place to take a leak.

  12. #11
    Seattle CTS-V's Avatar
    Seattle CTS-V is offline Cadillac Owners Connoisseur
    Automobile(s): '05 CTS-V (sold)
    Join Date
    Jun 2005
    Location
    WA
    Posts
    1,475

    Re: Coolant loss...

    I've had a few 'low coolant' messages over the past few months. I just top it off and forget about it. I haven't seen any evidence of a leak though.

  13. #12
    DmaxSierra's Avatar
    DmaxSierra is offline Cadillac Owners Member
    Automobile(s): 2005 CTS-V
    Join Date
    May 2007
    Posts
    26

    Re: Coolant loss...

    I also had the same problem...began around the first 100 miles. Initial problem was a faulty hose clamp which just cracked Replaced that myself. Then had the leaky radiator. Didn't actually see it dripping but had loss of coolant. Dealer re-crimped the lower radiator and she's been good for the last 5000 miles. They said that if it leaked again, then they would replace the radiator. Like stated previously...lots of faulty V radiators out there. As well as "faulty" differentials..but we won't go there

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting